Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17831 closed defect (duplicate)

Update to pyOpenSSL 0.14

Reported by: vbraun Owned by:
Priority: major Milestone: sage-6.6
Component: packages: optional Keywords:
Cc: dkrenn, schilly Merged in:
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #17832 Stopgaps:

Status badges

Description (last modified by vbraun)

Supposedly fixes the

/local/data/krenn/sage/6.5.rc2/local/include/openssl/ssl.h:156:0, 
                 from OpenSSL/crypto/x509.h:17, 
                 from OpenSSL/crypto/crypto.h:30, 
                 from OpenSSL/crypto/crl.c:3: 
/local/data/krenn/sage/6.5.rc2/local/include/openssl/x509.h:751:15: 
note: previous declaration of 'X509_REVOKED_dup' was here 
error: command 'gcc' failed with exit status 1 

bug but introduces a couple of new dependencies: cffi pyasn1 enum34 pycparser

Change History (8)

comment:1 Changed 6 years ago by vbraun

  • Component changed from PLEASE CHANGE to packages: optional
  • Description modified (diff)
  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 6 years ago by vbraun

  • Dependencies set to #17832

comment:3 Changed 6 years ago by dkrenn

  • Cc dkrenn added

comment:4 follow-up: Changed 6 years ago by tmonteil

Could you try just doing:

sage -pip install pyopenssl

It worked well for me. If this works for you as well, since pyopenssl spkg is optional and unmaintained (still uses the old spkg style), it could be a better idea to just remove it from the list of packages and benefit from the up-to-date pip one. We did that for sqlalchemy for example.

Last edited 6 years ago by tmonteil (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 6 years ago by dkrenn

Replying to tmonteil:

Could you try just doing:

sage -pip install pyopenssl

It worked well for me.

Works.

comment:6 follow-up: Changed 6 years ago by jdemeyer

Close as duplicate of #16897 then?

comment:7 Changed 6 years ago by vbraun

  • Authors set to Jeroen Demeyer
  • Resolution set to duplicate
  • Reviewers set to Volker Braun
  • Status changed from new to closed

comment:8 in reply to: ↑ 6 Changed 6 years ago by tmonteil

  • Cc schilly added

Replying to jdemeyer:

Close as duplicate of #16897 then?

I would say yes, but then pyopenssl should be removed from http://sagemath.org/packages/optional/ and http://sagemath.org/packages/optional/list to trigger an error.

Note: See TracTickets for help on using tickets.