Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#17813 closed enhancement (invalid)

help

Reported by: SimonKing Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: Merged in:
Authors: Reviewers: Simon King
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

I created this ticket by typing "git trac create help". What I obviously wanted was help on the git trac create command. So, perhaps we could use this accident to make a special case for the ticket description argument: If it is just "help" then no ticket should be created, but help should be provided?

See also #16656, #16980, #17052, #18248, #18313, #18314, #19655 and the branch name of #17796.

Change History (12)

comment:1 Changed 5 years ago by SimonKing

  • Component changed from PLEASE CHANGE to scripts
  • Description modified (diff)
  • Priority changed from major to minor

comment:2 Changed 5 years ago by jdemeyer

  • Description modified (diff)
  • Type changed from PLEASE CHANGE to enhancement

comment:3 Changed 5 years ago by vdelecroix

To obtain help within git you do "git help CMD". If you do for example "git branch help" then it would create the branch help. This beahvior is very gitish.

One possible fix would be that by default, there is a confirmation step: "you are about to create a new ticket called XYZ on trac, please confirm [Yes/no].". This confirmation could be removed by adding something from the configuration files.

Vincent

comment:4 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:5 follow-up: Changed 4 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #18248?

comment:6 in reply to: ↑ 5 Changed 4 years ago by SimonKing

Replying to jdemeyer:

Duplicate of #18248?

There are numerous duplicates, by construction of git. At least, with the latest version of git-trac, git trac create -h now shows help, rather than to create a ticket. So, I hope I will not accidentally create further tickets (no promise, though).

comment:7 Changed 4 years ago by jdemeyer

  • Reviewers set to Simon King
  • Status changed from needs_review to positive_review

comment:8 Changed 4 years ago by vbraun

  • Resolution set to invalid
  • Status changed from positive_review to closed

comment:9 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:10 follow-up: Changed 4 years ago by vbraun

There are shorter command lines with worse effects, how about sudo rm -rf /

Fun fact: that actually doesn't delete your files. At least with current coreutils. As I found out while trying to intentionally destroy a VM for testing purposes ;-)

comment:12 in reply to: ↑ 10 Changed 4 years ago by jdemeyer

Replying to vbraun:

There are shorter command lines with worse effects, how about sudo rm -rf /

At least that command makes it harder to accidentally Trac tickets.

Note: See TracTickets for help on using tickets.