Opened 4 years ago

Closed 20 months ago

#17768 closed defect (duplicate)

Morphism.is_identity() assumes a Morphism is determined by its action on gens()

Reported by: mmezzarobba Owned by:
Priority: major Milestone: sage-6.5
Component: algebra Keywords:
Cc: caruso, jakobkroeker Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps: wrongAnswerMarker

Description (last modified by mmezzarobba)

Counterexample:

sage: from sage.categories.morphism import SetMorphism
sage: f = SetMorphism(Hom(QQ, QQ, Sets()), numerator)
sage: f.is_identity()
True

See also #15478, #15381.

Change History (4)

comment:1 Changed 4 years ago by mmezzarobba

  • Description modified (diff)

comment:2 Changed 4 years ago by mmezzarobba

  • Description modified (diff)

comment:3 Changed 2 years ago by jakobkroeker

  • Cc jakobkroeker added
  • Stopgaps set to wrongAnswerMarker

comment:4 Changed 20 months ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15381.

Note: See TracTickets for help on using tickets.