Opened 6 years ago

Closed 6 years ago

#17746 closed enhancement (duplicate)

Let sage-native-execute also forget about Sage's own Python and its modified PATH.

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by tmonteil)

sage-native-execute aims at executing programs out of the sage virtual environment, by resetting some variables. However, Python-related ones are not reset, which causes trouble when one want to launch a command that depends on the system's Python. The PATH are also not reset. So, let us reset them too.

See #17735 and #14414.

Change History (6)

comment:1 Changed 6 years ago by tmonteil

  • Branch set to u/tmonteil/let_sage_native_execute_also_forget_about_sage_s_own_python_

comment:2 Changed 6 years ago by tmonteil

  • Authors set to Thierry Monteil
  • Branch u/tmonteil/let_sage_native_execute_also_forget_about_sage_s_own_python_ deleted
  • Description modified (diff)
  • Status changed from new to needs_review
  • Summary changed from Let sage-native-execute also forget about Sage's own Python. to Let sage-native-execute also forget about Sage's own Python and its modified PATH.

comment:3 Changed 6 years ago by tmonteil

  • Branch set to u/tmonteil/let_sage_native_execute_also_forget_about_sage_s_own_python_
  • Commit set to bc893f51f07d6bd8634fd632dabe949abf8fdafe

New commits:

bc893f5#17746 reset PYTHONHOME PYTHONPATH PATH

comment:4 Changed 6 years ago by tmonteil

  • Authors Thierry Monteil deleted
  • Description modified (diff)
  • Milestone changed from sage-6.5 to sage-duplicate/invalid/wontfix

My bad, it is a duplicate of #9386 and #10286 which i did not notice, i will work on them directly, sorry for the noise.

comment:5 Changed 6 years ago by vdelecroix

  • Branch u/tmonteil/let_sage_native_execute_also_forget_about_sage_s_own_python_ deleted
  • Commit bc893f51f07d6bd8634fd632dabe949abf8fdafe deleted
  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

comment:6 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.