Opened 6 years ago

Closed 6 years ago

#17738 closed enhancement (fixed)

Remove wrapper_parent.pyx

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-6.5
Component: coercion Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers: Marc Mezzarobba
Report Upstream: N/A Work issues:
Branch: 307c237 (Commits, GitHub, GitLab) Commit: 307c23792e9b9ede584c9dcef67de138767656ac
Dependencies: Stopgaps:

Status badges

Description (last modified by mmezzarobba)

The file src/sage/structure/wrapper_parent.pyx is nowhere used in Sage, not doctested, and hasn't seen any non-trivial change since 2008. Moreover, there is almost no actual code, so even if it's not broken, it doesn't do much. Just remove it.

Change History (7)

comment:1 Changed 6 years ago by jdemeyer

  • Branch set to u/jdemeyer/ticket/17738

comment:2 Changed 6 years ago by jdemeyer

  • Commit set to 307c23792e9b9ede584c9dcef67de138767656ac
  • Status changed from new to needs_review

New commits:

307c237Remove wrapper_parent

comment:3 follow-up: Changed 6 years ago by mmezzarobba

Why? Is it broken? Does it have a significant maintenance cost? Is there a better mechanism to achieve what it was intended for?

comment:4 in reply to: ↑ 3 Changed 6 years ago by jdemeyer

Replying to mmezzarobba:

Is it broken?

Given that it's not used, not doctested, and not maintained since 2008, it is very likely broken. Moreover, there is almost no actual code, so even if it's not broken, it doesn't do much.

Does it have a significant maintenance cost?

Not significant, but there is some maintanance cost: every time we deprecate or change something that this module uses, we have to update it.

Is there a better mechanism to achieve what it was intended for?

Your question seems to assume that this module itself achieves what it was intended for. I don't know if that's the case. Given the little code, I doubt it. In any case, I would need to understand better what it was intented for...

comment:5 Changed 6 years ago by jdemeyer

Let me also add that there is no discussion on Trac nor on sage-devel mentioning this module, so I very much doubt that it will be missed (and if so, it's still in the git history).

comment:6 Changed 6 years ago by mmezzarobba

  • Description modified (diff)
  • Reviewers set to Marc Mezzarobba
  • Status changed from needs_review to positive_review

Sound convincing :-)

comment:7 Changed 6 years ago by vbraun

  • Branch changed from u/jdemeyer/ticket/17738 to 307c23792e9b9ede584c9dcef67de138767656ac
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.