Opened 8 years ago

Closed 8 years ago

#17724 closed enhancement (fixed)

Rename PowerSeries.reversion() in PowerSeries.reverse()

Reported by: Bruno Grenet Owned by:
Priority: major Milestone: sage-6.5
Component: commutative algebra Keywords: reverse, series
Cc: Merged in:
Authors: Bruno Grenet Reviewers: Ralf Stephan
Report Upstream: N/A Work issues:
Branch: 05bbf4a (Commits, GitHub, GitLab) Commit: 05bbf4ad70765e6a1a8cdb3c3e6930231f2fbec8
Dependencies: Stopgaps:

Status badges


The method PowerSeries.reversion(self) returns the reverse power series of self. Following the apparent naming convention, I propose to rename it PowerSeries.reverse(self).

It is more consistent with other method such as (for PowerSeries): derivative() (not derivation) or truncate() (not truncation).

Change History (4)

comment:1 Changed 8 years ago by Bruno Grenet

Branch: u/bruno/rename_powerseries_reversion___in_powerseries_reverse__

comment:2 Changed 8 years ago by Bruno Grenet

Commit: 05bbf4ad70765e6a1a8cdb3c3e6930231f2fbec8
Status: newneeds_review
Type: PLEASE CHANGEenhancement

New commits:

05bbf4aReplace reversion by reverse

comment:3 Changed 8 years ago by Ralf Stephan

Reviewers: Ralf Stephan
Status: needs_reviewpositive_review

Looks fine. Thanks.

comment:4 Changed 8 years ago by Volker Braun

Branch: u/bruno/rename_powerseries_reversion___in_powerseries_reverse__05bbf4ad70765e6a1a8cdb3c3e6930231f2fbec8
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.