Opened 4 years ago

Closed 4 years ago

#17702 closed defect (fixed)

Fix long doctest in designs

Reported by: gouezel Owned by:
Priority: trivial Milestone: sage-duplicate/invalid/wontfix
Component: combinatorial designs Keywords:
Cc: ncohen Merged in:
Authors: Sebastien Gouezel Reviewers:
Report Upstream: N/A Work issues:
Branch: u/gouezel/iOA_long_doctest (Commits) Commit: daad37297eff79d7ee8c34989840d44f7e3e5105
Dependencies: Stopgaps:

Description

The following doctest is taken from combinat/designs/orthogonal_arrays.py:

sage: iOA = designs.incomplete_orthogonal_array(10,153,[9]*10) # long time
sage: OA9 = designs.orthogonal_arrays.build(10,9)
sage: for i in range(10):                                      
....:     iOA.extend([[153-9*(i+1)+x for x in B] for B in OA9])
sage: is_orthogonal_array(iOA,10,153)                          
True

It fails if tested without --long since the first line is not executed, so iOA is not defined in subsequent calls.

Change History (4)

comment:1 Changed 4 years ago by gouezel

  • Branch set to u/gouezel/iOA_long_doctest

comment:2 Changed 4 years ago by gouezel

  • Commit set to daad37297eff79d7ee8c34989840d44f7e3e5105
  • Status changed from new to needs_review

New commits:

daad372Ticket #17702: Fix long doctest in designs

comment:3 Changed 4 years ago by ncohen

  • Milestone changed from sage-6.5 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

Duplicate of #17672

comment:4 Changed 4 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.