Opened 8 years ago

Closed 15 months ago

#17690 closed enhancement (fixed)

Remove outdated SSL section in the "install from source code" documentation

Reported by: Thierry Monteil Owned by:
Priority: critical Milestone: sage-9.5
Component: documentation Keywords:
Cc: Samuel Lelièvre, William Stein, Dima Pasechnik Merged in:
Authors: Matthias Koeppe Reviewers: Thierry Monteil
Report Upstream: N/A Work issues:
Branch: 4e84ec8 (Commits, GitHub, GitLab) Commit: 4e84ec838b688821ac42770f724aa079bfaa7571
Dependencies: Stopgaps:

Status badges

Description (last modified by Matthias Köppe)

In the "install from source code" documentation, there are some sections on how to build Sage with SSL support, some of it in relation to the removed sagenb.

Since sage 9.3, openssl is a normal standard package.

We remove the outdated and confusing info.

Change History (11)

comment:1 Changed 8 years ago by Karl-Dieter Crisman

Good idea! In the past this was indeed just sagenb-specific.

comment:2 Changed 2 years ago by Matthias Köppe

Cc: Samuel Lelièvre William Stein Dima Pasechnik added; Nathann Cohen removed
Milestone: sage-6.5sage-9.3
Priority: majorcritical

We still need to replace the outdated instructions regarding 'secure notebook' by Jupyter/openssl instructions

comment:3 Changed 20 months ago by Matthias Köppe

Milestone: sage-9.3sage-9.4

comment:4 Changed 16 months ago by Matthias Köppe

Summary: A SSL section in the "install from source code" documentationRemove outdated SSL section in the "install from source code" documentation

comment:5 Changed 16 months ago by Matthias Köppe

Description: modified (diff)

comment:6 Changed 16 months ago by Matthias Köppe

Branch: u/mkoeppe/remove_outdated_ssl_section_in_the__install_from_source_code__documentation

comment:7 Changed 16 months ago by Matthias Köppe

Authors: Matthias Koeppe
Commit: 4e84ec838b688821ac42770f724aa079bfaa7571
Description: modified (diff)
Status: newneeds_review

New commits:

8ef9287src/doc/en/installation: Remove outdated ssl info
4e84ec8README.md: Remove outdated ssl info

comment:8 Changed 16 months ago by Thierry Monteil

Reviewers: Thierry Monteil
Status: needs_reviewpositive_review

LGTM.

comment:9 Changed 16 months ago by Matthias Köppe

Thanks!

comment:10 Changed 15 months ago by Matthias Köppe

Milestone: sage-9.4sage-9.5

comment:11 Changed 15 months ago by Volker Braun

Branch: u/mkoeppe/remove_outdated_ssl_section_in_the__install_from_source_code__documentation4e84ec838b688821ac42770f724aa079bfaa7571
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.