Opened 6 years ago

Closed 6 years ago

#17688 closed enhancement (fixed)

Upgrade optional arb spkg to 2.5.0

Reported by: fredrik.johansson Owned by:
Priority: minor Milestone: sage-6.5
Component: packages: optional Keywords: arb
Cc: cheuberg Merged in:
Authors: Clemens Heuberger Reviewers: Marc Mezzarobba, François Bissey
Report Upstream: N/A Work issues:
Branch: 3aece2b (Commits) Commit: 3aece2b80b95e76db63d7223d578fac240a775af
Dependencies: Stopgaps:

Change History (14)

comment:1 Changed 6 years ago by cheuberg

Fredrik, do you intend to prepare a patch or would you prefer that I do it?

comment:2 Changed 6 years ago by fredrik.johansson

Haven't really caught up with the Sage development process, so I'd appreciate if you could do it!

comment:3 Changed 6 years ago by cheuberg

  • Authors set to Clemens Heuberger
  • Branch set to u/cheuberg/packages/arb-2.5
  • Commit set to 3885e9f561a78c84363f31dbc42919bfd95ae5e3
  • Status changed from new to needs_review

I checked that the tarball provided in the description is the same as the one on the github site. The doctests in my non-merged tickets using arb (#17263 and its dependencies) pass.


Last 10 new commits:

225ee88Trac #17480: Combine description of def _add_ and cpdef _add_
b19a161Trac #17480: Replace "four" by "three" relevant functions
2e57cf9Trac #17480: Fix typo
0549c8aTrac #17480: Insist on subtle differences between methods
7ebe661Trac #17480: Language corrections
bcceb90element.pyx: more formatting fixes
6fbe471Trac #17480: Fix formatting of docstring of abs
6ee1bb8Merge remote-tracking branch 'trac/develop' into structure/element-doc
340fc4fTrac #17480: Two more ReSt fixes.
3885e9fTrac #17688: Upgrade arb spkg to 2.5.0

comment:4 Changed 6 years ago by cheuberg

  • Status changed from needs_review to needs_work

sorry, pushed wrong branch

comment:5 Changed 6 years ago by git

  • Commit changed from 3885e9f561a78c84363f31dbc42919bfd95ae5e3 to 0eb70b05d22108e2e64cb8423eb5f779fd300bb6

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

0eb70b0Trac #17688: Upgrade arb spkg to 2.5.0

comment:6 Changed 6 years ago by cheuberg

  • Status changed from needs_work to needs_review

comment:7 follow-up: Changed 6 years ago by mmezzarobba

  • Reviewers set to Marc Mezzarobba
  • Status changed from needs_review to positive_review

comment:8 in reply to: ↑ 7 ; follow-up: Changed 6 years ago by fbissey

Marc have you checked that arb is passing its own test suite (spkg-check)? I am fairly sure it won't because there is no release of flint2 with the right function for the testsuite not to fail. You would need a git checkout or someone making a new release of flint.

I have decided to make an ebuild of arb for gentoo (in the sage-on-gentoo overlay) and I got this when running "make check"

/home/extra/portage/sci-mathematics/arb-2.5.0/temp/ccLcbPFS.o: In function `acb_modular_epsilon_arg_naive':
/home/extra/portage/sci-mathematics/arb-2.5.0/work/arb-2.5.0/acb_modular/test/t-epsilon_arg.c:52: undefined reference to `fmpq_dedekind_sum'
collect2: error: ld returned 1 exit status
../Makefile.subdirs:78: recipe for target '../build/acb_modular/test/t-epsilon_arg' failed
make[1]: *** [../build/acb_modular/test/t-epsilon_arg] Error 1

No stable release of flint has fmpq_dedekind_sum in flint 2.4.4 as shipped with sage. It is still arith_dedekind_sum. And of course that's were it stopped, there could be more.

comment:9 Changed 6 years ago by fbissey

After patching it, I can confirm that it is the only failing test.

comment:10 in reply to: ↑ 8 Changed 6 years ago by mmezzarobba

Replying to fbissey:

Marc have you checked that arb is passing its own test suite (spkg-check)? I am fairly sure it won't because there is no release of flint2 with the right function for the testsuite not to fail. You would need a git checkout or someone making a new release of flint.

No, I haven't. I usually don't do touch spkgs and I didn't think it was relevant. Feel free to set the ticket back to needs_work, or set its milestone to pending depending what you think is appropriate. Thanks for the comment!

comment:11 Changed 6 years ago by fbissey

  • Status changed from positive_review to needs_work

I feel compelled to put it back to "needs_work" which is almost certainly what Volker would do especially if he reads my comments. Te merge window for non-critical stuff in 6.5 is closed anyway so it is a matter for the next release.

comment:12 Changed 6 years ago by git

  • Commit changed from 0eb70b05d22108e2e64cb8423eb5f779fd300bb6 to 3aece2b80b95e76db63d7223d578fac240a775af

Branch pushed to git repo; I updated commit sha1. New commits:

3aece2bTrac #17688: Patch tests of arb-2.5 to be compatible with flint-2.4.4

comment:13 Changed 6 years ago by fbissey

  • Reviewers changed from Marc Mezzarobba to Marc Mezzarobba, François Bissey
  • Status changed from needs_work to positive_review

looks good to me. back to positive.

comment:14 Changed 6 years ago by vbraun

  • Branch changed from u/cheuberg/packages/arb-2.5 to 3aece2b80b95e76db63d7223d578fac240a775af
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.