Opened 5 years ago

Closed 3 years ago

#17536 closed defect (invalid)

quo_rem fails for multivariate polynomial rings over function fields

Reported by: bhutz Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebraic geometry Keywords:
Cc: bhutz Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The quo_rem function fails for multivariate polynomial rings over function fields. This seems related to change #17033.

R.<c>=FunctionField(QQ)
S.<x,y>=R[]
f=x^4*y + 2*c*x^2*y^3 - x*y^4 + (c^2 + c)*y^5
g=x^2*y - x*y^2 + c*y^3
f.quo_rem(g)

Change History (6)

comment:1 Changed 5 years ago by bhutz

In working on #17535, I see that the failed example I list actually works with 6.5.beta3. Perhaps this has already been fixed somewhere.

comment:2 Changed 3 years ago by klee

  • Milestone changed from sage-6.5 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:3 Changed 3 years ago by tscrim

Do we want to add a doctest to prevent a regression since we don't know exactly what fixed this?

comment:4 Changed 3 years ago by bhutz

I wish I would have put what the failure was...

Looking at the code it does nothing put pass the input straight to singular and return the output from singular. Maybe the issue was the conversion of the singular output back to Sage or maybe it was issue with the Singular computation. I'm not sure at this point.

I don't think we need another specific test for this as it is tested implicitly in some of the schememorphism_polynomial functionality (for example in dynatomic_polynomial as well as in homogenize/dehomogenize). That is how I found the issue in the first place.

comment:5 Changed 3 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

Okay. Then we can close as works-for-me.

comment:6 Changed 3 years ago by vbraun

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.