Opened 4 years ago

Closed 4 years ago

#17463 closed defect (fixed)

Remove the deprecated 'dim' argument of MIP variables

Reported by: ncohen Owned by:
Priority: major Milestone: sage-6.7
Component: numerical Keywords:
Cc: dimpase Merged in:
Authors: Nathann Cohen Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: d3c8f90 (Commits) Commit: d3c8f902e77b87fb1a1f6406d04a04127683f452
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

The 'dim' attribute of MIPVariables has been deprecated since Sage 6.2 in #15489. It was always useless since myvar[a,b] works and is more practical than myvar[a][b]. I had not noticed that when I implemented it T_T

With this ticket, the problem is solved.

Change History (17)

comment:1 Changed 4 years ago by ncohen

  • Branch set to u/ncohen/17463
  • Status changed from new to needs_review

comment:2 Changed 4 years ago by git

  • Commit set to d3c8f902e77b87fb1a1f6406d04a04127683f452

Branch pushed to git repo; I updated commit sha1. New commits:

d3c8f90Removed 'MIPVariable.dim' attribute deprecated in #15489 on 2013-12-06

comment:3 Changed 4 years ago by dimpase

  • Status changed from needs_review to positive_review

LGTM

comment:4 Changed 4 years ago by ncohen

Thanks !

Nathann

comment:5 Changed 4 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-6.5 to sage-pending

comment:6 Changed 4 years ago by jdemeyer

  • Summary changed from Remove the (deprecate) 'dim' argument of MIP variables to Remove the deprecated 'dim' argument of MIP variables

comment:7 Changed 4 years ago by vbraun

I hope you don't expect me to merge "sage-pending" tickets...

comment:8 Changed 4 years ago by ncohen

I do not object to changing the milestone and having it merged tomorrow, if you ask.

Nathann

comment:9 Changed 4 years ago by vbraun

I'm neither the author nor the reviewer (name missing btw).

comment:10 Changed 4 years ago by ncohen

  • Reviewers set to Dima Pasechnik

comment:11 follow-up: Changed 4 years ago by vbraun

PSA: Once you want the ticket merged you can set a milestone to something else than "sage-pending"

comment:12 in reply to: ↑ 11 Changed 4 years ago by ncohen

PSA: Once you want the ticket merged you can set a milestone to something else than "sage-pending"

Right right. I asked google calendar to send me an email on the 2015-05-06.

Nathann

comment:13 Changed 4 years ago by vbraun

Just trying to make sure that everybody understands that feature of the merge script since it caused some confusion on another ticket

comment:14 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-pending to sage-6.7

comment:15 Changed 4 years ago by ncohen

Oh. Thanks :-D

comment:16 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:17 Changed 4 years ago by vbraun

  • Branch changed from u/ncohen/17463 to d3c8f902e77b87fb1a1f6406d04a04127683f452
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.