Opened 6 years ago

Closed 6 years ago

#17422 closed defect (duplicate)

symbolic sums with known parameters should simplify()

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by rws)

A minimal case:

sage: (k,n) = var('k,n')
sage: sum(abs(-k*k+n),k,1,n)
sum(abs(-k^2 + n), k, 1, n)
sage: _(n=8)
sum(abs(-k^2 + 8), k, 1, 8)
sage: _.simplify()
sum(abs(k^2 - 8), k, 1, 8)

I would expect _.simplify() or .expand() to give me the result 162 but this does not work.

Related to #9424. One may depend on the other. Relevant questions were:

Change History (6)

comment:1 Changed 6 years ago by rws

  • Description modified (diff)

comment:2 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.5 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #15346.

comment:3 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:4 Changed 6 years ago by rws

  • Branch set to u/rws/symbolic_sums_with_known_parameters_should_simplify__

comment:5 Changed 6 years ago by rws

  • Branch u/rws/symbolic_sums_with_known_parameters_should_simplify__ deleted

comment:6 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.