Opened 8 years ago

Closed 8 years ago

#17334 closed enhancement (fixed)

Update libgd to 2.1.0

Reported by: Jean-Pierre Flori Owned by:
Priority: major Milestone: sage-6.4
Component: packages: standard Keywords:
Cc: Travis Scrimshaw, Volker Braun Merged in:
Authors: Jean-Pierre Flori Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 809967a (Commits, GitHub, GitLab) Commit: 809967a03e077d988435fc91c04567ec0890dc96
Dependencies: Stopgaps:

Status badges

Description (last modified by Jean-Pierre Flori)

2.0.x is not supported anymore upstream.

The Sage scripts also need a lot of cleanup.

As far as Cygwin is concerned, we still need to:

Autoreconfed tarball at:

Change History (4)

comment:1 Changed 8 years ago by Jean-Pierre Flori

Cc: Travis Scrimshaw added
Component: PLEASE CHANGEpackages: standard
Type: PLEASE CHANGEenhancement

comment:2 Changed 8 years ago by Jean-Pierre Flori

Authors: Jean-Pierre Flori
Branch: u/jpflori/ticket/17334
Cc: Volker Braun added
Commit: 809967a03e077d988435fc91c04567ec0890dc96
Description: modified (diff)
Status: newneeds_review

New commits:

4cf1a0cUpdate gd to version 2.1.0.
f86127aUpstream gd is now libgd.
d0b9f02Missed checksum update after gd->libgd move.
809967aRemove -fPIC from gd CFLAGS as libtool is used and smart enough.

comment:3 Changed 8 years ago by Volker Braun

Reviewers: Volker Braun
Status: needs_reviewpositive_review

comment:4 Changed 8 years ago by Volker Braun

Branch: u/jpflori/ticket/17334809967a03e077d988435fc91c04567ec0890dc96
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.