Opened 7 years ago

Closed 6 years ago

#17208 closed defect (fixed)

gsl testsuite failure on OSX 10.10

Reported by: vbraun Owned by:
Priority: major Milestone: sage-6.4
Component: packages: standard Keywords: yosemite
Cc: Merged in:
Authors: Volker Braun Reviewers: John Palmieri
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: e06c1b0 (Commits, GitHub, GitLab) Commit: e06c1b0ef3009135203578379b3678cc534d82c2
Dependencies: Stopgaps:

Status badges

Description (last modified by vbraun)

Full log attached, testsuite errors start with:

make  check-TESTS
FAIL: gsl_sf_mathieu_se(1, 5.0, M_PI_2, &r) [2613]
  expected: 1.3374338870223450e+00
  obtained: 1.0000000000000000e+00 +/- 4.4408920985006262e-16 (rel=4.44089e-16)
  fracdiff: 1.4436082615889587e-01
 tolerance: 9.9999999999999995e-07
  value/expected not consistent within reported error
  value not within tolerance of expected value
  1.000000000000000000e+00  4.440892098500626162e-16

This is with our own gcc, it works with clang.

Upstream bug reports:

Attachments (1)

gsl-1.15.p1.log (449.1 KB) - added by vbraun 7 years ago.
Compile log

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by vbraun

Compile log

comment:1 Changed 7 years ago by vbraun

Should be fixed by #17214

Edit: No its not.

Last edited 7 years ago by vbraun (previous) (diff)

comment:2 Changed 7 years ago by vbraun

  • Description modified (diff)
  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

comment:3 Changed 7 years ago by jhpalmieri

Any chance this will be fixed by #17214? (I can't test it on an OSX 10.10 machine right now.)

comment:4 Changed 7 years ago by vbraun

No, same with gsl-1.16 (see comment:1)

comment:5 Changed 7 years ago by vbraun

  • Description modified (diff)

comment:6 Changed 7 years ago by vbraun

Can reproduce failure on Linux x86_64 with CFLAGS='-O2 -fPIC -mtune=corei7'

comment:7 Changed 7 years ago by jhpalmieri

I see the same failure on OSX 10.9 (with Sage 6.4.rc1, and probably with any version with gcc 4.9.x).

comment:8 Changed 6 years ago by vbraun

  • Branch set to u/vbraun/gsl_testsuite_failure_on_osx_10_10

comment:9 Changed 6 years ago by vbraun

  • Authors set to Volker Braun
  • Commit set to e06c1b0ef3009135203578379b3678cc534d82c2
  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, in a later stable release.
  • Status changed from new to needs_review

Patch fixes the testsuite failure.


New commits:

e06c1b0Add upstream PR 63661

comment:10 Changed 6 years ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

This works on three different OS X machines. I haven't tested it on other architectures, but since it's an upstream patch, I think that's good enough.

comment:11 Changed 6 years ago by vbraun

  • Branch changed from u/vbraun/gsl_testsuite_failure_on_osx_10_10 to e06c1b0ef3009135203578379b3678cc534d82c2
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.