Opened 7 years ago

Closed 7 years ago

#17071 closed defect (duplicate)

Polybori segfaults

Reported by: vbraun Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I've seen this sporadically on the buildbot recently, but not before 6.4.beta3:

sage -t --long --warn-long 51.5 src/sage/crypto/mq/sr.py  # 6 doctests failed
sage -t --long --warn-long 51.5 src/sage/rings/polynomial/multi_polynomial_sequence.py  # 9 doctests failed
sage -t --long --warn-long 51.5 src/sage/rings/polynomial/pbori.pyx  # Killed due to segmentation fault

Its strange because we didn't upgrade polybori recently.

Change History (5)

comment:1 Changed 7 years ago by fbissey

But we upgraded m4ri and polybori depends on it. It has to be rebuilt.

comment:2 Changed 7 years ago by vbraun

True. I just noticed that the buildbot skipped a beat and accidentally built an old version, and after that the segfaults started.

comment:3 follow-up: Changed 7 years ago by jdemeyer

Duplicate of #17072?

comment:4 in reply to: ↑ 3 Changed 7 years ago by fbissey

Replying to jdemeyer:

Duplicate of #17072?

I guess so.

comment:5 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.