Opened 5 years ago

Closed 5 years ago

#17003 closed task (fixed)

Upgrade ECL to 13.5.1

Reported by: pbruin Owned by:
Priority: minor Milestone: sage-6.4
Component: packages: standard Keywords: ecl
Cc: fbissey, jpflori Merged in:
Authors: Peter Bruin Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: 1ef485c (Commits) Commit: 1ef485c7f665c406b22d4b5a7d8ec1054b36b2a2
Dependencies: #12985, #16908 Stopgaps:

Change History (7)

comment:1 Changed 5 years ago by pbruin

  • Branch set to u/pbruin/17003-ecl-13.5.1
  • Cc fbissey jpflori added
  • Commit set to 1ef485c7f665c406b22d4b5a7d8ec1054b36b2a2
  • Dependencies changed from #12985 to #12985, #16908
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 follow-up: Changed 5 years ago by fbissey

We have to force rebuild of maxima after the upgrade and I think there are minor doctest failures that are caused by the upgrade namely a few like this one:

sage -t --long /usr/share/sage/src/sage/interfaces/maxima_lib.py
**********************************************************************
File "/usr/share/sage/src/sage/interfaces/maxima_lib.py", line 902, in sage.interfaces.maxima_lib.MaximaLib.sr_limit
Failed example:
    limit(x^a,x=0)
Expected:
    Traceback (most recent call last):
    ...
    ValueError: Computation failed ...
    Is a an integer?
Got:
    <BLANKLINE>
    Traceback (most recent call last):
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 480, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 843, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.interfaces.maxima_lib.MaximaLib.sr_limit[7]>", line 1, in <module>
        limit(x**a,x=Integer(0))
      File "/usr/lib64/python2.7/site-packages/sage/calculus/calculus.py", line 1251, in limit
        l = maxima.sr_limit(ex, v, a)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 952, in sr_limit
        self._missing_assumption(s)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 997, in _missing_assumption
        raise ValueError(outstr)
    ValueError: Computation failed since Maxima requested additional constraints; using the 'assume' command before evaluation *may* help (example of legal syntax is 'assume(a>0)', see `assume?` for more details)
    Is a an ?integer?
**********************************************************************

Not sure if the blank line cause the failure but "?integer?" instead of "integer?" probably does. I am not sure what the "?" is for. There is at least another doctest failing that way.

comment:3 Changed 5 years ago by fbissey

calculus.py

sage -t --long /usr/share/sage/src/sage/calculus/calculus.py
**********************************************************************
File "/usr/share/sage/src/sage/calculus/calculus.py", line 1098, in sage.calculus.calculus.limit
Failed example:
    limit(x^a,x=0)
Expected:
    Traceback (most recent call last):
    ...
    ValueError: Computation failed since Maxima requested additional
    constraints; using the 'assume' command before evaluation *may* help
    (example of legal syntax is 'assume(a>0)', see `assume?` for
     more details)
    Is a an integer?
Got:
    <BLANKLINE>
    Traceback (most recent call last):
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 480, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 843, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.calculus.calculus.limit[13]>", line 1, in <module>
        limit(x**a,x=Integer(0))
      File "/usr/lib64/python2.7/site-packages/sage/calculus/calculus.py", line 1251, in limit
        l = maxima.sr_limit(ex, v, a)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 952, in sr_limit
        self._missing_assumption(s)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 997, in _missing_assumption
        raise ValueError(outstr)
    ValueError: Computation failed since Maxima requested additional constraints; using the 'assume' command before evaluation *may* help (example of legal syntax is 'assume(a>0)', see `assume?` for more details)
    Is a an ?integer?
**********************************************************************
File "/usr/share/sage/src/sage/calculus/calculus.py", line 1107, in sage.calculus.calculus.limit
Failed example:
    limit(x^a,x=0)
Expected:
    Traceback (most recent call last):
    ...
    ValueError: Computation failed since Maxima requested additional
    constraints; using the 'assume' command before evaluation *may* help
    (example of legal syntax is 'assume(a>0)', see `assume?` for
     more details)
    Is a an even number?
Got:
    <BLANKLINE>
    Traceback (most recent call last):
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 480, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/usr/lib64/python2.7/site-packages/sage/doctest/forker.py", line 843, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.calculus.calculus.limit[15]>", line 1, in <module>
        limit(x**a,x=Integer(0))
      File "/usr/lib64/python2.7/site-packages/sage/calculus/calculus.py", line 1251, in limit
        l = maxima.sr_limit(ex, v, a)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 952, in sr_limit
        self._missing_assumption(s)
      File "/usr/lib64/python2.7/site-packages/sage/interfaces/maxima_lib.py", line 997, in _missing_assumption
        raise ValueError(outstr)
    ValueError: Computation failed since Maxima requested additional constraints; using the 'assume' command before evaluation *may* help (example of legal syntax is 'assume(a>0)', see `assume?` for more details)
    Is a an ?even?\ ?number?
**********************************************************************

comment:4 in reply to: ↑ 2 Changed 5 years ago by pbruin

Replying to fbissey:

We have to force rebuild of maxima after the upgrade

With the current branch, make should automatically build the new Maxima 5.34.1 due to the dependency on #16908, unless you already did a previous build of #16908, in which case you indeed have to reinstall Maxima.

and I think there are minor doctest failures that are caused by the upgrade

I cannot reproduce these. The printing of question marks should be suppressed by build/pkgs/maxima/patches/undoing_true_false_printing_patch.patch; did that somehow fail to apply?

comment:5 Changed 5 years ago by fbissey

No, that's a patch I am missing in sage-on-gentoo, it flew under my radar. I thought they were related to ecl.

comment:6 Changed 5 years ago by fbissey

  • Reviewers set to François Bissey
  • Status changed from needs_review to positive_review

OK, I actually cheated in #12985 I actually did the testing straight away with the new ecl. I want this to go in, same comments as in #12985 but the version bump should definitely trigger a rebuild.

A side note, #12985 enables ecl to be used with or without unicode. That is ecl compiled without unicode will work just as well with the patch to sage - so long that maxima and sage are properly compiled against that version.

comment:7 Changed 5 years ago by vbraun

  • Branch changed from u/pbruin/17003-ecl-13.5.1 to 1ef485c7f665c406b22d4b5a7d8ec1054b36b2a2
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.