Opened 6 years ago

Closed 6 years ago

#16807 closed defect (fixed)

Overflow error in conversion Integer -> FiniteFieldElement_pari_ffelt

Reported by: pbruin Owned by:
Priority: major Milestone: sage-6.4
Component: finite rings Keywords: pari overflow
Cc: Merged in:
Authors: Peter Bruin Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: 596fc84 (Commits) Commit: 596fc84235207901f23cec6f843540f43087e12e
Dependencies: Stopgaps:

Description

As reported by Samuel Neves on sage-support, the following raises a PARI error due to an overflow in converting from t_INT to long:

p = previous_prime(2^64)
F.<x> = GF(p^2)
x * 2**63

The problem is that the conversion is done using PARI's itos (t_INT to signed long) instead of itou (t_INT to unsigned long).

Change History (3)

comment:1 Changed 6 years ago by pbruin

  • Branch set to u/pbruin/16807-finite_field_overflow
  • Commit set to 596fc84235207901f23cec6f843540f43087e12e
  • Status changed from new to needs_review

comment:2 Changed 6 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:3 Changed 6 years ago by vbraun

  • Branch changed from u/pbruin/16807-finite_field_overflow to 596fc84235207901f23cec6f843540f43087e12e
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.