Changes between Version 21 and Version 22 of Ticket #16759


Ignore:
Timestamp:
09/09/15 11:42:02 (5 years ago)
Author:
jdemeyer
Comment:

I vote for removing the install_package() command. Installing packages from within Sage can never work properly anyway:

  1. for some packages, you need to rebuild the Sage library, which cannot be done in Sage.
  2. some packages might need a change in environment variables (e.g. ccache) and that can only be done if sage-env is re-run after installing the package.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #16759

    • Property Summary changed from Fix install_package() to install_package() is obsolete
    • Property Dependencies changed from #15642, #18407 to
  • Ticket #16759 – Description

    v21 v22  
    1 `install_package()` fails because `standard_packages()` does not parse correctly the output given by the shell command `sage --standard`.
    2 
    3 Similar for `optional_packages()` and `experimental_packages`.
    4 
    5 ----
    6 
    7 The ''parsing'' issue is now fixed by #18407, but the ''logical'' issues (cf. [comment:2 the comment below]) remain to get fixed.
     1Packages should be installed using `sage -i` from a shell, not with the `install_package()` Sage command.