Opened 7 years ago

Closed 6 years ago

#16693 closed defect (duplicate)

doctests of attributes and of end_doc are not tested

Reported by: dkrenn Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest framework Keywords: doctests not tested
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In #16677 we added a documentation for the attribute is_initial of the class FSMState in the file sage/combinat/finite_state_machine.py and added some doctests there. Those are not tested at all, which shouldn't be. MOreover, doctests which are in end_doc, as for example in sage/combinat/dyck_word.py are also not tested.

Change History (4)

comment:1 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:2 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #14272.

comment:3 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:4 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.