Opened 7 years ago

Closed 7 years ago

#16692 closed enhancement (fixed)

Update nose to version 1.3.3

Reported by: mraum Owned by:
Priority: major Milestone: sage-6.3
Component: packages: optional Keywords:
Cc: jhpalmieri Merged in:
Authors: Martin Raum Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: 65f66d3 (Commits, GitHub, GitLab) Commit: 65f66d33b785494bbf8d946db2fc924131093a1e
Dependencies: Stopgaps:

Status badges

Description (last modified by jhpalmieri)

Current version is 1.3.3, which comes with some improvements that can be useful for smooth integration into Sage. E.g. the nose.loader module is more complete now.

Upstream at

http://boxen.math.washington.edu/home/palmieri/SPKG/nose-1.3.3.tar.bz2

Change History (11)

comment:1 Changed 7 years ago by mraum

  • Branch set to u/mraum/ticket/16692
  • Created changed from 07/21/14 09:02:24 to 07/21/14 09:02:24
  • Modified changed from 07/21/14 09:02:24 to 07/21/14 09:02:24

comment:2 Changed 7 years ago by mraum

  • Commit set to d15815d4bf1fbcc50a0816e8eaadaf635bfe4fc1
  • Description modified (diff)
  • Status changed from new to needs_review

New commits:

d15815dUpdate nose testing framework.

comment:3 Changed 7 years ago by jhpalmieri

  • Reviewers set to John Palmieri

Mostly looks good. I think the script spkg-src should deleted: it won't work as currently written, and it doesn't look like it's needed with the current version. Otherwise this is good to go.

Last edited 7 years ago by jhpalmieri (previous) (diff)

comment:4 Changed 7 years ago by mraum

Thanks for looking at this so quickly.

Concerning spkg-src, I simply renamed spkg-make. The reason is the section on Modified Tarballs at http://sagemath.github.io/git-developer-guide/packaging.html.

comment:5 Changed 7 years ago by jhpalmieri

I understand that you renamed spkg-make to spkg-src, but this script won't run successfully: first, it will quit if it doesn't find a file spkg-make in the current directory, and second, it expects to find the old-style spkg directory structure, so it expects to find a src directory which it will modify. Finally, all it does is remove .pyc files, and the most recent version of nose that I downloaded didn't have any of those. So I think it should be deleted.

comment:6 Changed 7 years ago by git

  • Commit changed from d15815d4bf1fbcc50a0816e8eaadaf635bfe4fc1 to 65f66d33b785494bbf8d946db2fc924131093a1e

Branch pushed to git repo; I updated commit sha1. New commits:

65f66d3Remove obsolute spkg-src

comment:7 Changed 7 years ago by mraum

Sorry, you are absolutely right.

comment:8 Changed 7 years ago by jhpalmieri

  • Status changed from needs_review to positive_review

comment:9 Changed 7 years ago by vbraun

  • Status changed from positive_review to needs_work

comment:10 Changed 7 years ago by jhpalmieri

  • Description modified (diff)
  • Status changed from needs_work to positive_review

Sorry about that. I made a copy in my account on boxen (see the modified description), and this should be accessible.

comment:11 Changed 7 years ago by vbraun

  • Branch changed from u/mraum/ticket/16692 to 65f66d33b785494bbf8d946db2fc924131093a1e
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.