Opened 5 years ago

Closed 5 years ago

#16524 closed enhancement (fixed)

OA(9,135)

Reported by: ncohen Owned by:
Priority: major Milestone: sage-6.3
Component: combinatorial designs Keywords:
Cc: vdelecroix Merged in:
Authors: Nathann Cohen Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: a0294d3 (Commits) Commit: a0294d3b5b6d2e1cbf6f3f5dd625df765350a478
Dependencies: #16503 Stopgaps:

Description

A new one !

Nathann

Change History (26)

comment:1 Changed 5 years ago by ncohen

  • Branch set to u/ncohen/16524
  • Dependencies changed from 16347 to #16347
  • Status changed from new to needs_review

comment:2 Changed 5 years ago by git

  • Commit set to d94b4c6daccc0544ccd14a6bd0235d97fe4af8c2

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

03c1f45trac #16430: Small speedup for OA(None,p^c)
8e8a9f3trac #16430: Merged with 6.3.beta4
162b83ctrac #16430: Many bugfixes
3e01acbtrac #16430: micro improvements
81b9448trac #16430: put back the seealso
d3f9702trac #16347: merge #16430
8bcbe6ftrac #16437: fix MOLS table doctest
49169d5trac #16437: use is_sum_of_two_squares and fix error msg
1d1a476trac #16347: optimize find_wilson_decomposition
d94b4c6trac #16524: OA(9,135)

comment:3 Changed 5 years ago by ncohen

  • Dependencies changed from #16347 to #16500

comment:4 Changed 5 years ago by ncohen

  • Dependencies changed from #16500 to #16503

comment:5 Changed 5 years ago by git

  • Commit changed from d94b4c6daccc0544ccd14a6bd0235d97fe4af8c2 to 4148cc472331568ec20ed614c10895edb040bbf8

Branch pushed to git repo; I updated commit sha1. This was a forced push. Last 10 new commits:

e64be98trac #16423: tiny code improvement and alignment
e948cf6trac #16423: Aligning the alignment
0a7d853trac #16423: Broken doctests
b329351trac #16499: Cheap speedup in the OA recursive constructions
a67c04ftrac #16500: New recursive constructions of Orthogonal Arrays
41c50d5trac #16500: Simplified find_recursive_construction
e1992cetrac #16500: doc + speedup
697dd0ctrac #16500: Typoes in the doc
71dad5dtrac #16503: q-x construction of Orthogonal Arrays
4148cc4trac #16524: OA(9,135)

comment:6 Changed 5 years ago by git

  • Commit changed from 4148cc472331568ec20ed614c10895edb040bbf8 to 002ceee1c2cd49be71135d710057a9dea1de81c8

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

002ceeetrac #16524: OA(9,135)

comment:7 follow-up: Changed 5 years ago by vdelecroix

  • Status changed from needs_review to needs_info

Hi Nathann,

This is not clear (at least to me)

This is possible, because `PG(2,2)` is a subdesign in `PG(2,16)`; in a
cyclic `PG(2,16)` or `BIBD(273,17,1)` the points `\equiv 0 \pmod{39}`
form such a subdesign.

It would be better to have the (273,17,1) from the difference family constructor... I just did it and there is an extra check in the doc that it is actually a cyclic one: u/vdelecroix/16524.

Vincent

comment:8 Changed 5 years ago by git

  • Commit changed from 002ceee1c2cd49be71135d710057a9dea1de81c8 to c6e78c8f358758c88fd5fe7d806c9ead5e503a33

Branch pushed to git repo; I updated commit sha1. New commits:

c6e78c8trac #16524: move the cyclic difference set to the constructor

comment:9 in reply to: ↑ 7 ; follow-up: Changed 5 years ago by ncohen

Yo !

This is not clear (at least to me)

This is possible, because `PG(2,2)` is a subdesign in `PG(2,16)`; in a
cyclic `PG(2,16)` or `BIBD(273,17,1)` the points `\equiv 0 \pmod{39}`
form such a subdesign.

Ahahahah. It is "Julian Abel's truth". And as the constructions works... :-)

It would be better to have the (273,17,1) from the difference family constructor... I just did it and there is an extra check in the doc that it is actually a cyclic one: u/vdelecroix/16524.

I just pushed it to the branch, but in the future I guess that we will remove this function as we add the patch of all DF found in the handbook. We will not create a function for each of them, and it will be a dictionary ... Anyway !

Nathann

comment:10 in reply to: ↑ 9 ; follow-up: Changed 5 years ago by vdelecroix

Replying to ncohen:

Yo !

This is not clear (at least to me)

This is possible, because `PG(2,2)` is a subdesign in `PG(2,16)`; in a
cyclic `PG(2,16)` or `BIBD(273,17,1)` the points `\equiv 0 \pmod{39}`
form such a subdesign.

Ahahahah. It is "Julian Abel's truth". And as the constructions works... :-)

I mean, what is a PG? what do you mean by points \equiv 0 \pmod{39}?

It would be better to have the (273,17,1) from the difference family constructor... I just did it and there is an extra check in the doc that it is actually a cyclic one: u/vdelecroix/16524.

I just pushed it to the branch, but in the future I guess that we will remove this function as we add the patch of all DF found in the handbook. We will not create a function for each of them, and it will be a dictionary ... Anyway !

Of course, it is on my todo list... but in the meantime let us continue the way we started!

Vincent

comment:11 in reply to: ↑ 10 Changed 5 years ago by ncohen

Yo !

I mean, what is a PG? what do you mean by points \equiv 0 \pmod{39}?

Oh ! Well, a projective plane ! PG = Projective Geometry. And the points congruent to = mod 39 are somehow "defined" as it is a cyclic design on 273 points.

Of course, it is on my todo list... but in the meantime let us continue the way we started!

Yepyep...

Nathann

comment:12 Changed 5 years ago by vdelecroix

Hi,

More docs at u/vdelecroix/16524. It is the only method where the notation PG is used!! If you like, take it and set to positive review...

Vincent

comment:13 follow-up: Changed 5 years ago by ncohen

Hmmmm... I don't like to change his words but well... Okay, if you prefer...

Nathann

comment:14 Changed 5 years ago by git

  • Commit changed from c6e78c8f358758c88fd5fe7d806c9ead5e503a33 to a0294d3b5b6d2e1cbf6f3f5dd625df765350a478

Branch pushed to git repo; I updated commit sha1. New commits:

a0294d3trac #16524: more comments in the doc

comment:15 Changed 5 years ago by ncohen

  • Status changed from needs_info to needs_review

comment:16 Changed 5 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix

comment:17 in reply to: ↑ 13 Changed 5 years ago by vdelecroix

  • Status changed from needs_review to positive_review

comment:18 Changed 5 years ago by ncohen

thanks !

comment:19 Changed 5 years ago by vbraun

  • Status changed from positive_review to needs_work
Traceback (most recent call last):
  File "/home/release/Sage/src/doc/common/builder.py", line 1490, in <module>
    getattr(get_builder(name), type)()
  File "/home/release/Sage/src/doc/common/builder.py", line 291, in _wrapper
    getattr(get_builder(document), 'inventory')(*args, **kwds)
  File "/home/release/Sage/src/doc/common/builder.py", line 502, in _wrapper
    x.get(99999)
  File "/home/release/Sage/local/lib/python/multiprocessing/pool.py", line 558, in get
    raise self._value
OSError: [combinat ] /home/release/Sage/local/lib/python2.7/site-packages/sage/combinat/designs/orthogonal_arrays_recursive.py:docstring of sage.combinat.designs.orthogonal_arrays_recursive.construction_q_x:65: ERROR: Unexpected indentation.

comment:20 Changed 5 years ago by vbraun

Actually the bug is in #16503

comment:21 Changed 5 years ago by ncohen

  • Status changed from needs_work to positive_review

comment:22 Changed 5 years ago by ncohen

Can't reproduce it ...

Nathann

comment:23 Changed 5 years ago by vdelecroix

  • Status changed from positive_review to needs_work

Update to do, see #16503.

comment:24 follow-up: Changed 5 years ago by ncohen

  • Status changed from needs_work to positive_review

No conflict -> no update needed. Stop making me work for nothing, or do it yourself.

Nathann

comment:25 in reply to: ↑ 24 Changed 5 years ago by vdelecroix

Replying to ncohen:

No conflict -> no update needed. Stop making me work for nothing, or do it yourself.

Note: above this branch, the doc does not build. Should merge #16503 first.

comment:26 Changed 5 years ago by vbraun

  • Branch changed from u/ncohen/16524 to a0294d3b5b6d2e1cbf6f3f5dd625df765350a478
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.