Opened 7 years ago

Closed 7 years ago

#16489 closed defect (duplicate)

Handle capitalization in sage-fix-pkg-checksums

Reported by: robertwb Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: Merged in:
Authors: Reviewers: Robert Bradshaw, Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: u/robertwb/ticket/16489 (Commits, GitHub, GitLab) Commit: 4775c793f8fcda4ae17c3aafaf7ff494ebc4526b
Dependencies: Stopgaps:

Status badges

Description

A couple of packages (Cython and Pillow) have capitalized upstream tarballs. This works fine, but the pkg-fixing script ignores such packages.

Change History (6)

comment:1 Changed 7 years ago by robertwb

  • Branch set to u/robertwb/ticket/16489
  • Created changed from 06/17/14 08:14:32 to 06/17/14 08:14:32
  • Modified changed from 06/17/14 08:14:32 to 06/17/14 08:14:32

comment:2 Changed 7 years ago by robertwb

  • Authors set to Robert Bradshaw
  • Commit set to 4775c793f8fcda4ae17c3aafaf7ff494ebc4526b
  • Status changed from new to needs_review

New commits:

4775c79Handle capitalization in sage-fix-pkg-checksums.

comment:3 Changed 7 years ago by charpent

See http://trac.sagemath.org/ticket/16629 for a solution of another bug that might also fix this.

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 7 years ago by jdemeyer

  • Authors Robert Bradshaw deleted
  • Component changed from build to scripts
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Robert Bradshaw, Jeroen Demeyer
  • Status changed from needs_review to positive_review

Duplicate of the more general #16629.

comment:6 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.