Opened 7 years ago

Closed 6 years ago

#16481 closed defect (duplicate)

Use stricter sse-2 check for gf2x

Reported by: emassop Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: jpflori Merged in:
Authors: emassop Reviewers:
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: u/emassop/gf2x_sse_2 (Commits, GitHub, GitLab) Commit: 10e8e3b4447eeee0cfede059b19284b8dddcf3ca
Dependencies: Stopgaps:

Status badges

Description

A build failure occurred for me in gf2x. The sse-2 test yielded

checking whether gcc -std=gnu99 can compile and run sse-2 code... yes

while if should yield

checking whether gcc -std=gnu99 can compile and run sse-2 code... requires -msse2

Recent revisions in gf2x svn have a stricter test that yields the right result for me.

Here is the log:

====================================================
Setting up build directory for gf2x-1.1.p0
Finished set up
****************************************************
Host system:
Linux alfa.ixsop.nl 3.14.6-1-ARCH #1 SMP PREEMPT Sun Jun 8 10:57:49 CEST 2014 i686 GNU/Linux
****************************************************
C compiler: gcc
C compiler version:
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-pc-linux-gnu/4.9.0/lto-wrapper
Target: i686-pc-linux-gnu
Configured with: /build/gcc/src/gcc-4.9-20140604/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-cloog-backend=isl --disable-cloog-version-check --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --disable-multilib --disable-werror --enable-checking=release
Thread model: posix
gcc version 4.9.0 20140604 (prerelease) (GCC) 
****************************************************
patching file Makefile.am
patching file Makefile.in
Configuring gf2x.
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to print strings... printf
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... ld
checking if the linker (ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert i686-pc-linux-gnu file names to i686-pc-linux-gnu format... func_convert_file_noop
checking how to convert i686-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for ld used by g++... ld
checking if the linker (ld) is GNU ld... yes
checking whether the g++ linker (ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (ld) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking warning verbosity option... -Wall -W for C++ -Wall -W for C
checking for gcc option to accept ISO C99... -std=gnu99
checking build system compiler gcc -std=gnu99... yes
checking for build system executable suffix... 
checking whether gcc -std=gnu99 and cc understand -c and -o together... yes
checking size of unsigned long... 4
checking whether gcc -std=gnu99 can compile and run sse-2 code... yes
checking whether gcc -std=gnu99 can compile pclmulqdq and if it is supported by the hardware... no
configure: using ABI="default"
configure:       CC="gcc -std=gnu99"
configure:       CFLAGS="-O2 -g  -Wall -W"
configure:       CPPFLAGS=""
configure:       hwdir="x86_sse2"
checking the number of bits in an unsigned long... 32
checking whether already_tuned/x86_sse2/ is right assuming 32-bits unsigned longs... yes
configure: creating ./config.status
config.status: creating version.sh
config.status: creating Makefile
config.status: creating tests/Makefile
config.status: creating apps/Makefile
config.status: creating src/Makefile
config.status: creating gf2x/gf2x-config.h
config.status: linking already_tuned/x86_sse2/gf2x-thresholds.h to gf2x/gf2x-thresholds.h
config.status: linking already_tuned/x86_sse2/gf2x_mul1.h to gf2x/gf2x_mul1.h
config.status: linking already_tuned/x86_sse2/gf2x_mul2.h to gf2x/gf2x_mul2.h
config.status: linking already_tuned/x86_sse2/gf2x_mul3.h to gf2x/gf2x_mul3.h
config.status: linking already_tuned/x86_sse2/gf2x_mul4.h to gf2x/gf2x_mul4.h
config.status: linking already_tuned/x86_sse2/gf2x_mul5.h to gf2x/gf2x_mul5.h
config.status: linking already_tuned/x86_sse2/gf2x_mul6.h to gf2x/gf2x_mul6.h
config.status: linking already_tuned/x86_sse2/gf2x_mul7.h to gf2x/gf2x_mul7.h
config.status: linking already_tuned/x86_sse2/gf2x_mul8.h to gf2x/gf2x_mul8.h
config.status: linking already_tuned/x86_sse2/gf2x_mul9.h to gf2x/gf2x_mul9.h
config.status: executing depfiles commands
config.status: executing libtool commands
Building gf2x.
make[3]: Entering directory '/home/erik/sage/local/var/tmp/sage/build/gf2x-1.1.p0/src'
Making all in .
make[4]: Entering directory '/home/erik/sage/local/var/tmp/sage/build/gf2x-1.1.p0/src'
/bin/sh ./libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I./gf2x  -I. -I.   -O2 -g  -Wall -W -MT gf2x.lo -MD -MP -MF .deps/gf2x.Tpo -c -o gf2x.lo gf2x.c
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I./gf2x -I. -I. -O2 -g -Wall -W -MT gf2x.lo -MD -MP -MF .deps/gf2x.Tpo -c gf2x.c  -fPIC -DPIC -o .libs/gf2x.o
gf2x.c: In function 'gf2x_mul_pool_init':
gf2x.c:82:24: warning: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Wsizeof-pointer-memaccess]
     memset(p, 0, sizeof(p));
                        ^
In file included from gf2x/gf2x-small.h:102:0,
                 from gf2x.c:31:
./gf2x/gf2x_mul3.h: In function 'gf2x_mul3':
./gf2x/gf2x_mul3.h:82:12: warning: SSE vector return without SSE enabled changes the ABI [-Wpsabi]
     g[2] = SHL(g[1], 1);
            ^
In file included from ./gf2x/gf2x_mul3.h:34:0,
                 from gf2x/gf2x-small.h:102,
                 from gf2x.c:31:
/usr/lib/gcc/i686-pc-linux-gnu/4.9.0/include/emmintrin.h:1145:1: error: inlining failed in call to always_inline '_mm_slli_epi64': target specific option mismatch
 _mm_slli_epi64 (__m128i __A, int __B)
 ^
In file included from gf2x/gf2x-small.h:102:0,
                 from gf2x.c:31:
./gf2x/gf2x_mul3.h:82:12: error: called from here
     g[2] = SHL(g[1], 1);
            ^
In file included from ./gf2x/gf2x_mul3.h:34:0,
                 from gf2x/gf2x-small.h:102,
                 from gf2x.c:31:
/usr/lib/gcc/i686-pc-linux-gnu/4.9.0/include/emmintrin.h:1145:1: error: inlining failed in call to always_inline '_mm_slli_epi64': target specific option mismatch
 _mm_slli_epi64 (__m128i __A, int __B)
 ^
In file included from gf2x/gf2x-small.h:102:0,
                 from gf2x.c:31:
./gf2x/gf2x_mul3.h:84:12: error: called from here
     g[4] = SHL(g[2], 1);
            ^

etc. etc. etc.

Change History (8)

comment:1 Changed 7 years ago by emassop

  • Summary changed from Use stricted sse-2 check for gf2x to Use stricter sse-2 check for gf2x

comment:2 Changed 7 years ago by emassop

  • Branch set to u/emassop/gf2x_sse_2

comment:3 Changed 7 years ago by emassop

  • Authors set to emassop
  • Cc jpflori added
  • Commit set to 10e8e3b4447eeee0cfede059b19284b8dddcf3ca
  • Status changed from new to needs_review

comment:4 Changed 7 years ago by jpflori

Note that upstream can still fial in some cases IIRC. We've worked on this with Jeroen at #15316 which you review in place of this ticket.

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:6 Changed 6 years ago by vbraun

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix

Propose to close this as duplicate of #15316, then

comment:7 Changed 6 years ago by jpflori

  • Status changed from needs_review to positive_review

I agree.

comment:8 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.