Opened 7 years ago

Closed 7 years ago

#16480 closed enhancement (fixed)

Upgrade readline to version 6.3

Reported by: emassop Owned by:
Priority: major Milestone: sage-6.4
Component: packages: standard Keywords:
Cc: vbraun, stephen Merged in:
Authors: Erik Massop Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: b49ec14 (Commits, GitHub, GitLab) Commit: b49ec14fc1bc82ebae6c1f71d69d3c71edcdb394
Dependencies: #16260 Stopgaps:

Status badges

Description (last modified by vbraun)

This is needed to build on Arch. (Of course the build breaks again when Arch gets the next readline version and corresponding bash.)

The tarball is at http://www.ixsop.nl/sage/readline-6.3.008.tar.gz.

Change History (21)

comment:1 Changed 7 years ago by emassop

  • Branch set to u/emassop/readline_6_3

comment:2 Changed 7 years ago by git

  • Commit set to e0d9941e91c93cd2a24a5bd3bd1e0a316c10f31f

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

e0d9941Upgrade readline to version 6.3

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:4 Changed 7 years ago by aapitzsch

Python in Sage has been updated to 2.7.8.

Is this patch ready for review?

comment:5 Changed 7 years ago by emassop

  • Authors set to Erik Massop
  • Cc vbraun added
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to enhancement

Wow, it has been two months since I built Sage (and ran into errors).

Yes, I think this is ready for review now.

Last edited 7 years ago by emassop (previous) (diff)

comment:6 Changed 7 years ago by aapitzsch

It works on archlinux. But somebody else has to test it on other supported platforms.

comment:7 Changed 7 years ago by emassop

Builds and passes sage -t --long --all for me on Debian Squeeze-LTS x86_64. Can't review since I'm author on this ticket.

The most significant change is for OS/X, so it should definitely be tested there.

The file shobj-conf.patch does more than described in SPKG.txt. Those extra things should probably be removed from shobj-conf.patch or added in SPKG.txt. I do not, however, think that this is part of "upgrade to readline 6.3". Also I can't do this, as I don't have access to BSD or non-ELF systems.

comment:8 Changed 7 years ago by jhpalmieri

This builds and seems to work well on OS X 10.9. Any suggestions for how to test it thoroughly?

comment:9 Changed 7 years ago by git

  • Commit changed from e0d9941e91c93cd2a24a5bd3bd1e0a316c10f31f to 1f850123f87da833af464fc292fc65cc35f16124

Branch pushed to git repo; I updated commit sha1. New commits:

1f85012Simplify patches after more thorough investigation

comment:10 Changed 7 years ago by emassop

I dug into the revision history to see what various chunks of shobj-conf.patch were for.

The FreeBSD related chunks seem to be remnants from FreeBSD's transition from a.out to ELF. Upstream has code for that now, so I discarded those chunks.

For OS/X, I traced the changes back to a patch on macports. There the patch has been updated and I have included the new version now. I think this is the sane thing to do for OS/X. Anyway, that patch has been included in macports for 4 months now, and there are no open bugs at https://trac.macports.org/query?status=assigned&status=new&status=reopened&component=ports&summary=~readline&order=priority so that should be fine.

comment:11 Changed 7 years ago by emassop

  • Cc stephen added

I'm CC-ing Stephen because of the FreeBSD-related things. With readline 6.3 I think it should be possible to drop patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install and patch-build_pkgs_readline_patches_shobj-conf.patch from the port at http://svnweb.freebsd.org/ports/head/math/sage/ .

comment:12 Changed 7 years ago by emassop

Okay, now I can crash Sage by typing some random text and then tapping the up-arrow a number of times. This is a known Readline 6.3 bug, reported here, and fixed here. I would like to get Readline at a higher patch-level, at least version 6.3.002.

Automatically generated tarballs are available from http://git.savannah.gnu.org/cgit/readline.git/log/. However I am unsure if the checksums are always the same. Moreover the top-level directory in those tarballs have a name that Sage doesn't like for renaming to src.

Should I upload a tarball with a renamed top-level directory somewhere? Or should I add (some of) the patches from ftp://ftp.cwru.edu/pub/bash/readline-6.3-patches/ in git and apply them from spkg_install?

comment:13 Changed 7 years ago by vbraun

Its preferable to host the tarball somewhere under your control.

comment:14 Changed 7 years ago by git

  • Commit changed from 1f850123f87da833af464fc292fc65cc35f16124 to 79c17b39730895f6d49cc5afc8b90fb8870319f9

Branch pushed to git repo; I updated commit sha1. New commits:

79c17b3Use tarball for Readline version 6.3.008

comment:15 Changed 7 years ago by emassop

  • Description modified (diff)

Generated tarball for Readline 6.3.008, using

$ git clone git://git.sv.gnu.org/readline.git
$ git archive --format=tar.gz --prefix=readline-6.3.008/ -o readline-6.3.008.tar.gz HEAD

if you want to reproduce it. (HEAD should of course be at Readline-6.3 patch 8.) It's available at http://www.ixsop.nl/sage/readline-6.3.008.tar.gz.

comment:16 Changed 7 years ago by git

  • Commit changed from 79c17b39730895f6d49cc5afc8b90fb8870319f9 to b49ec14fc1bc82ebae6c1f71d69d3c71edcdb394

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

b49ec14Update to Readline version 6.3.008

comment:17 Changed 7 years ago by luran

Are we waiting for a review on the FreeBSD related changes? I only have a machine running Arch, and so I can't help that.

comment:18 Changed 7 years ago by vbraun

Does it work with our Python? If yes somebody please update the description.

comment:19 Changed 7 years ago by emassop

  • Description modified (diff)

Yes, it works with current Sage's Python. That comment in the description refers to #16260 which has been done a while now.

comment:20 Changed 7 years ago by vbraun

  • Description modified (diff)
  • Reviewers set to Volker Braun

comment:21 Changed 7 years ago by vbraun

  • Branch changed from u/emassop/readline_6_3 to b49ec14fc1bc82ebae6c1f71d69d3c71edcdb394
  • Resolution set to fixed
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.