Opened 13 years ago

Closed 12 years ago

#1646 closed defect (duplicate)

'matrix in group' test doesn't work

Reported by: schilly Owned by: joyner
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: group theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The code

G = SL(2,ZZ)                 
M = matrix([[1,0],[0,1]])    
M in G            


runs possibly forever inside GAP. same for

M = matrix(ZZ,[[1,0],[0,1]])

Change History (7)

comment:1 Changed 13 years ago by mabshoff

  • Milestone set to sage-2.9.2

comment:2 Changed 13 years ago by mabshoff

  • Priority changed from major to critical

comment:3 Changed 13 years ago by mhansen

This is due to GAP. Unless we get GAP to fix this, then the best solution would be for SL to override the contains method.

comment:4 Changed 13 years ago by wdj

  • Component changed from linear algebra to group_theory
  • Owner changed from was to joyner

I've reported this to GAP support.

comment:5 Changed 13 years ago by wdj

from Laurent Bartholdi <laurent.bartholdi@…> to David Joyner <wdjoyner@…>, cc GAP Support <support@…>, date Jan 24, 2008 5:36 PM subject Re: [GAP Support] membership in SL(2,Z) mailed-by gmail.com hide details 5:36 PM (27 minutes ago) Reply It's not intentional, and should be fixed. Here's a quick solution:

InstallMethod?(\in,[IsMatrix?,IsSpecialLinearGroup?],

function(g,G)

return Length(g)=Length(One(G)) and

ForAll?(g,row->Length(row)=Length(One(g)) and IsOne?(DeterminantMat?(g));

end);

needless to say, there must be lots of other missing methods; e.g. for general, symplectic etc. linear groups.

  • Hide quoted text -

On Jan 24, 2008 9:16 PM, David Joyner <wdjoyner@…> wrote:

Hi:

I wonder if the behavior of

gap> G := SL(2,Integers); SL(2,Integers) gap> g := 1,0],[0,1?; [ [ 1, 0 ], [ 0, 1 ] ] gap> g in G; user interrupt at ....

is intentional: it just hangs, as far as I can tell. Unless I'm doing something wrong, I wonder if an error message should be returned? Perhaps "method not implemented" or something?

  • David Joyner

_ Support mailing list Support@… http://mail.gap-system.org/mailman/listinfo/support

-- Laurent Bartholdi \ laurent.bartholdi<at>gmail<dot>com EPFL SB SMA IMB MAD \ Téléphone: +41 21-6935458 Station 8 \ Secrétaire: +41 21-6935471 CH-1015 Lausanne, Switzerland \ Fax: +41 21-6930339 Home address: http://f34.com/68

comment:6 Changed 12 years ago by AlexGhitza

This is a duplicate of #1834, which has been fixed and merged in 3.1.2.alpha4.

comment:7 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.1.2 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

Alex,

Thanks for finding the dupe. Closed as duplicate.

Cheers,

Michael

Note: See TracTickets for help on using tickets.