Opened 7 years ago

Closed 19 months ago

#16302 closed defect (duplicate)

"sage -tp 4 --all --long --optional=sage,internet" fails with 14 modules

Reported by: wluebbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: slabbe Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: u/wluebbe/ticket/16302 (Commits, GitHub, GitLab) Commit: 644063412711ec1213c96772c200854c56717150
Dependencies: Stopgaps:

Status badges

Description (last modified by wluebbe)

Testing with optional=sage,internet fails with 14 modules on Sage 6.2 (and before):

NbrModule and failures Status
1src/doc/en/bordeaux_2008/modular_forms_and_hecke_operators.rst # 1 doctest failed this ticket
2src/doc/en/developer/coding_basics.rst # 1 doctest failed open
3src/sage/combinat/sloane_functions.py # 1 doctest failed this ticket
4src/sage/combinat/species/library.py # 4 doctests failed open
5src/sage/combinat/tutorial.py # 1 doctest failed this ticket
6src/sage/combinat/words/paths.py # 1 doctest failed open
7src/sage/databases/oeis.py # 15 doctests failed #16252
8src/sage/dev/digest_transport.py # 1 doctest failed open
9src/sage/dev/patch.py # 3 doctests failed open
10src/sage/dev/sagedev.py # 2 doctests failed open
11src/sage/dev/trac_interface.py # 5 doctests failed open
12src/sage/finance/stock.py # 11 doctests failed open
13src/sage/misc/package.py # 1 doctest failed open
14src/sage/misc/preparser.py # 1 doctest failed open

The analysis should be documented in the comments.
Fixes as separate ticket (please reference them in the status column) or in this ticket (if appropriate).

Attachments (1)

failures-internet.txt (45.2 KB) - added by wluebbe 7 years ago.
Output from the failed doctests

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by wluebbe

Output from the failed doctests

comment:1 Changed 7 years ago by wluebbe

  • <1> Changed http://oeis.org/ response: a blank was removed.
  • <2> sloane_sequence(60843) is called. This should be adapted to DeprecationWarning: The function sloane_sequence is deprecated. Use oeis() instead (2012-01-01). See http://trac.sagemath.org/10358 for details.. - The module sloane.py is no more suitable to illustrate the point in coding_basics.rst lines 790 - 810 (2 different optional PKGNAMEs in one module).
  • <3> Apparently OEIS A111775 was changed to offset=1 while the Sage function is still initialized with offset=0.
  • <4> TypeError: 'NoneType' object has no attribute '__getitem__' was raised in all 4 failures (after calling oeis(seq)[0]). Testing the examples at a sage: prompt is successful while the doctest fails reproducible. Hmm ...?
  • <5> Changed http://oeis.org/ response. Expected response should be adapted.
  • <6> The expected response appears pretty printed (just as at the sage: prompt!) but the doctest response is a single line! How comes? Should the expected response be changed to a single line?
  • <7> is caused by changed http://oeis.org/ responses that do not match the (old) expected results. This is addressed by #16252.
  • <8> The expected response appears pretty printed (just as at the sage: prompt!) but the doctest response is a single line! See also <6>.
  • <9> 1. failure: Looks somewhat like the pretty print phenomenon. But this time the result at the sage: prompt matched the gotten doctest result.
  • <9> 2. failure: URLError: <urlopen error unknown url type: https> was raised. Apparently the Sage Python was built without ssl. Is that the cause?
  • <9> 3. failure: TracInternalError: <Fault 404: 'ticket does not exist'> was raised.
  • <9> I just noticed that all failures happened in MercurialPatchMixin.download_patch! Is this still needed ???
  • <10> Testing the examples at a sage: prompt is successful while the doctest fails reproducible. See also <4>?
  • <11> 1. failure: Pretty print is expected (same as from sage: prompt).
  • <11> 2. & 3. failure: AttributeError: 'DoctestTicketProxy' object has no attribute 'changeLog' raised respective no attribute 'query'.
  • <11> 4. & 5. failure: TracInternalError: <Fault 404: 'ticket does not exist'> after calling dev.trac.attachment_names(). Testing from sage: prompt give the expected response.
  • <12> Doctesting stock.py gives 11 failures; sometimes the response is empty, sometimes the responses differ from the expected. Testing at the sage: prompt gives the same results as the doctest. Apparently the requested data is no more available (too old?) from the web service. - Module needs updating.
  • <13> The response (also verified with the sage: prompt) deviates strongly from the expected sage.misc.package.install_all_optional_packages(dry_run=True).
  • <14> sage.misc.preparser.load('https://github.com/jasongrout/minimum_rank/raw/minimum_rank_1_0_0/minrank.py', globals()) raised IOError: [Errno url error] unknown url type: 'https'. Apparently Python has no ssl support.

Comments and help are appreciated :-)

Last edited 7 years ago by wluebbe (previous) (diff)

comment:2 Changed 7 years ago by wluebbe

  • Description modified (diff)

comment:3 Changed 7 years ago by wluebbe

  • Branch set to u/wluebbe/ticket/16302
  • Commit set to 644063412711ec1213c96772c200854c56717150
  • Description modified (diff)

New commits:

d323842fixed doctest failure for "sage -t --optional=sage,internet"
3cf32fefixed doctest failure for "sage -t --optional=sage,internet"
6440634fixed doctest failure for "sage -t --optional=sage,internet"

comment:4 Changed 7 years ago by wluebbe

These are patches for <1>, <3> and <5>.

Yes, the titles of the commit messages could have been better :-/
But look at the full messages ...

comment:5 Changed 7 years ago by leif

  • Milestone changed from sage-6.2 to sage-6.3

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:7 Changed 5 years ago by kcrisman

See also #20182.

comment:8 Changed 19 months ago by chapoton

  • Cc slabbe added
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

obsolete duplicate of #25536 ?

comment:9 Changed 19 months ago by kcrisman

I think you are correct.

comment:10 Changed 19 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from needs_review to closed

then I close this as duplicate

Note: See TracTickets for help on using tickets.