Opened 7 years ago

Closed 7 years ago

#16290 closed defect (duplicate)

UnboundLocalError in jordan_form

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Using sage-6.0:

sage: m = identity_matrix(2)
sage: m.jordan_form()
[1|0]
[-+-]
[0|1]
sage: m.jordan_form(base_ring=QQ)
Traceback (most recent call last):
...
UnboundLocalError: local variable 'A' referenced before assignment

Change History (4)

comment:1 Changed 7 years ago by slabbe

  • Milestone changed from sage-6.2 to sage-duplicate/invalid/wontfix

Sorry, this is a duplicate of #14508.

comment:2 Changed 7 years ago by aapitzsch

  • Status changed from new to needs_review

comment:3 Changed 7 years ago by aapitzsch

  • Status changed from needs_review to positive_review

comment:4 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.