Opened 7 years ago

Closed 6 years ago

#16259 closed enhancement (duplicate)

allow pkg installation via sage -i http://github.com/...tarball.tar.gz

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords: spkg, installation, http
Cc: leif Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Github projects, when tagged via git tag, get automatically packaged (see project page / releases), and the URL has a standardized form, as well as the tarball. So, it would be most convenient if a project like patchbot that adheres to the SPKG directory structure could be installed by just saying

sage -i https://github.com/robertwb/sage-patchbot/archive/2.1.1.tar.gz

Sage would then take the PACKAGE_NAME from SPKG.txt, or it could be given as optional argument to sage -i.

Change History (7)

comment:1 Changed 7 years ago by leif

  • Cc leif added

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:4 Changed 6 years ago by rws

  • Milestone changed from sage-6.4 to sage-wishlist

comment:5 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #16501.

comment:6 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:7 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.