Changes between Initial Version and Version 3 of Ticket #16242


Ignore:
Timestamp:
04/30/14 09:11:40 (5 years ago)
Author:
slabbe
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #16242

    • Property Status changed from new to needs_review
    • Property Commit changed from to ecc5f70423cf25c566fd8f30364a3ffe295d6ad8
    • Property Branch changed from to u/slabbe/16242
    • Property Authors changed from to Sébastien Labbé
  • Ticket #16242 – Description

    initial v3  
    1 I installed {{{sage -i dot2tex}}} and then, the method {{{assert_have_dot2tex}}} says that {{{dot2tex not available}}}.
     1I installed {{{sage -i dot2tex}}} and then I get an error saying that {{{dot2tex not available}}}:
     2
     3{{{
     4sage: G = DiGraph()
     5sage: G.add_edge(3333, 88, 'my_label')
     6sage: G.set_latex_options(format='dot2tex')
     7sage: view(G)
     8Traceback (most recent call last):
     9...
     10RuntimeError: dot2tex not available.
     11}}}
    212
    313The reason is that the function {{{assert_have_dot2tex}}} replaces the {{{ImportError}}} (in my case a pyparsing importerror) by a {{{RuntimeError}}} with the {{{dot2tex not available}}} message. This hides the real error.