Opened 15 years ago

Closed 15 years ago

#1622 closed defect (fixed)

[with spkg] update gnutls to 2.2.1

Reported by: Michael Abshoff Owned by: Michael Abshoff
Priority: major Milestone: sage-2.10.1
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description


Change History (7)

comment:1 Changed 15 years ago by Michael Abshoff

Owner: changed from William Stein to Michael Abshoff
Status: newassigned

comment:2 Changed 15 years ago by Yi Qiang

Summary: update gnutls to 2.2.0update gnutls to 2.3.0

They just released 2.3.0 so we might as well update to the latest.

http://www.gnu.org/software/gnutls/releases/gnutls-2.3.0.tar.bz2

comment:3 Changed 15 years ago by Yi Qiang

I just tried to create spkg's for it and everything is dandy except python-gnutls. There are major changes to the openpgp parts of gnutls which causes the pytho-gnutls not to work. I've contacted the author of python-gnutls to see if he'll update the wrapper.

comment:4 Changed 15 years ago by Yi Qiang

Also, here is a list of related packages that need to be updated as well:

opencdk libgcrypt libgpg-error python-gnutls

comment:5 in reply to:  4 Changed 15 years ago by Michael Abshoff

Replying to yi:

Also, here is a list of related packages that need to be updated as well:

opencdk libgcrypt libgpg-error python-gnutls

You are correct that once we update GNUTLS we at least need to update OpenCDK, but I will also update the others in one swoop. I will do this after I switch python to ucs4 though, which is the big goal for alpha2.

Cheers,

Michael

comment:6 Changed 15 years ago by Michael Abshoff

Summary: update gnutls to 2.3.0[with spkg] update gnutls to 2.2.1

An updated spkg with 64 bit OSX Mac support is at:

http://sage.math.washington.edu/home/mabshoff/release-cycles-2.10.1/alpha0/gnutls-2.2.1.spkg

Cheers,

Michael

comment:7 Changed 15 years ago by Michael Abshoff

Resolution: fixed
Status: assignedclosed

Merged in Sage 2.10.1.alpha0

Note: See TracTickets for help on using tickets.