Opened 4 years ago

Closed 3 years ago

#16113 closed defect (fixed)

Ctrl-C while sage -b

Reported by: vbraun Owned by:
Priority: major Milestone: sage-6.4
Component: build Keywords:
Cc: nthiery, robertwb Merged in:
Authors: Volker Braun Reviewers: Jeroen Demeyer
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: cf3f073 (Commits) Commit: cf3f073dd109eb05905ce245fe672e369d9df7f0
Dependencies: #16912 Stopgaps:

Description (last modified by vbraun)

Interrupting (Ctrl-C) in the parallel builder for the sage extension modules (sage -b) sometimes doesn't work.

Steps to reproduce:

  • sage -ba
  • press Ctrl-C after the cythonization started

Change History (21)

comment:1 Changed 4 years ago by vbraun

  • Cc nthiery added
  • Component changed from PLEASE CHANGE to build
  • Description modified (diff)
  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 4 years ago by vbraun

  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

comment:3 Changed 4 years ago by vbraun

  • Branch set to u/vbraun/ctrl_c_while_sage__b

comment:4 Changed 4 years ago by vbraun

  • Commit set to f4d0ff2a7309457e96bb97b4e26249536f6da114
  • Description modified (diff)
  • Status changed from new to needs_review

New commits:

f4d0ff2make sage -b interruptable

comment:5 Changed 4 years ago by jdemeyer

  • Cc robertwb added

I think we should wait for an upstream answer.

comment:6 Changed 4 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 3 years ago by malb

  • Status changed from needs_review to needs_info

comment:8 Changed 3 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:9 Changed 3 years ago by jdemeyer

  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, in a later stable release.

Should be fixed by Cython 0.21, see #16912.

comment:10 Changed 3 years ago by jdemeyer

#16912 indeed fixes this during the Cythonizing phase, but the GCC phase which uses distutils (I guess?) still exhibits the same problem.

comment:11 Changed 3 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer

I see, you have a patch for setup.py also.

comment:12 Changed 3 years ago by jdemeyer

  • Dependencies set to #16912

comment:13 Changed 3 years ago by jdemeyer

  • Branch changed from u/vbraun/ctrl_c_while_sage__b to u/jdemeyer/ticket/16113
  • Created changed from 04/09/14 17:26:30 to 04/09/14 17:26:30
  • Modified changed from 09/01/14 08:21:16 to 09/01/14 08:21:16

comment:14 Changed 3 years ago by jdemeyer

  • Commit changed from f4d0ff2a7309457e96bb97b4e26249536f6da114 to f02ceccc4b0d506628c249d0956b157080775850

Do we need maxtasksperchild=1 in the Pool() constructor?


New commits:

e1caed9Remove Cython patch
91276f1Upgrade to Cython 0.21
f02ceccMerge branch 'ticket/16912' into ticket/16113

comment:15 Changed 3 years ago by jdemeyer

  • Status changed from needs_info to needs_review

comment:16 Changed 3 years ago by git

  • Commit changed from f02ceccc4b0d506628c249d0956b157080775850 to 3d9db043296e865fb644c431aa6350d48d66e5e8

Branch pushed to git repo; I updated commit sha1. New commits:

3d9db04Remove maxtasksperchild=1

comment:17 Changed 3 years ago by vbraun

  • Authors set to Volker Braun
  • Status changed from needs_review to positive_review

lgtm

comment:18 Changed 3 years ago by vbraun

  • Status changed from positive_review to needs_work

Conflicts with the Cython upgrade since you force pushed at #16912..

comment:19 Changed 3 years ago by git

  • Commit changed from 3d9db043296e865fb644c431aa6350d48d66e5e8 to cf3f073dd109eb05905ce245fe672e369d9df7f0

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

7abf02bUpgrade to Cython 0.21
cf3f073Make sage -b interruptable

comment:20 Changed 3 years ago by jdemeyer

  • Status changed from needs_work to positive_review

comment:21 Changed 3 years ago by vbraun

  • Branch changed from u/jdemeyer/ticket/16113 to cf3f073dd109eb05905ce245fe672e369d9df7f0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.