Opened 8 years ago

Closed 5 years ago

#16035 closed defect (wontfix)

RealLazyField element comparison breaks on OSX

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords:
Cc: Merged in:
Authors: Reviewers: Dima Pasechnik, John Palmieri
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This is from #13125, (comment 22):

...it seems to fail only when comparing to zero (OSX 10.7.5):

sage: filter(lambda x: RLF(x) < -oo, range(-10,10))
[0]
sage: filter(lambda x: RLF(float(x)/3) < -oo, range(-10,10))
[0]

while on Linux I get:

sage: filter(lambda x: RLF(x) < -oo, range(-10,10))
[]
sage: filter(lambda x: RLF(float(x)/3) < -oo, range(-10,10))
[]

Change History (10)

comment:1 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:3 Changed 5 years ago by mkoeppe

This seems to work fine with 7.4.beta0 on Mac OS X 10.11.5.

comment:4 Changed 5 years ago by mkoeppe

  • Milestone changed from sage-6.4 to sage-7.4

comment:5 Changed 5 years ago by dimpase

this is OK on FreeBSD 11.0 with clang 3.8, I get the same answers ([]) as on Linux.

comment:6 Changed 5 years ago by chapoton

  • Milestone changed from sage-7.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

It seems that we can close this one

comment:7 Changed 5 years ago by dimpase

Well, a test on OSX is certainly needed 1st.

comment:8 Changed 5 years ago by jhpalmieri

Works for me on OS X 10.11.6, Sage 8.0.beta0.

comment:9 Changed 5 years ago by dimpase

  • Reviewers set to Dima Pasechnik, John Palmieri
  • Status changed from needs_review to positive_review

comment:10 Changed 5 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.