Opened 5 years ago

Closed 5 years ago

#16008 closed enhancement (fixed)

inclusion of the ore_algebra within Sage

Reported by: zimmerma Owned by:
Priority: major Milestone: sage-6.2
Component: packages: optional Keywords: gfun Mgfun Ore guessing
Cc: mkauers, schilly Merged in:
Authors: Reviewers: Marc Mezzarobba, Ralf Stephan
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by vbraun)

the group of Manuel Kauers at RISC develops the ore_algebra package (http://www.risc.jku.at/research/combinat/software/ore_algebra/index.php) which is similar to the Maple gfun package (but more powerful since it works in more general rings), and will be extended to the multivariate case. A small example with version 0.1:

  sage: from ore_algebra import *
  sage: R.<x> = QQ[]; A.<Dx> = OreAlgebra(R)
  sage: deq = guess([1,1,2,3,5,8,13,21],A)
  sage: deq
  (x^2 + x - 1)*Dx + 2*x + 1
  sage: rec = A(deq).to_S(A2)
  sage: rec
  (-n - 2)*Sn^2 + (n + 2)*Sn + n + 2

New optional spkg: http://www.risc.jku.at/research/combinat/software/ore_algebra/ore_algebra-0.1.spkg

Change History (20)

comment:1 Changed 5 years ago by rws

  • Cc rws added

See also #15714 and the meta ticket #11515. Of course ore_algebra has more in it than just guessing.

comment:2 Changed 5 years ago by rws

  • Component changed from algebra to packages: optional
  • Status changed from new to needs_review

comment:3 Changed 5 years ago by mmezzarobba

Hmm, what is it that needs review here?

comment:4 Changed 5 years ago by rws

  • Status changed from needs_review to positive_review

Well I thought I can't set both review and positive... but since you reviewed it too, I'll just go ahead. Thanks.

comment:5 Changed 5 years ago by mmezzarobba

  • Status changed from positive_review to needs_work

I don't understand: ore_algebra is not included in sage, is it? It is not even an optional package, just an external package that uses sage and happens to be distributed as an spkg...

comment:6 follow-up: Changed 5 years ago by rws

  • Status changed from needs_work to needs_review

This ticket is closed when ore_algebra is included as optional package. Any other code you need to use the package should go in another ticket.

comment:7 in reply to: ↑ 6 Changed 5 years ago by mmezzarobba

Replying to rws:

This ticket is closed when ore_algebra is included as optional package.

But it isn't, is it?

~/co/sage:develop$ ls build/pkgs/ore*
ls: cannot access build/pkgs/ore*: No such file or directory
(exit 2) 
~/co/sage:develop$ sage -optional | grep ore
(exit 1) 

Or did you forget to attach a branch to this ticket?

comment:8 follow-up: Changed 5 years ago by rws

But why? It's all included in the SPKG and works. Also, the docs state: Note that the top-level directory inside the tarball is renamed to src before calling the spkg-install script. So you really mean that I should provide an spkg-install script that calls the package's spkg-install script? Should it overwrite other files in build/... with versions in the provided package itself?

comment:9 in reply to: ↑ 8 Changed 5 years ago by mmezzarobba

Replying to rws:

But why? It's all included in the SPKG and works.

Sure, ore_algebra is available as an spkg. It already was Paul openeed this ticket. So the way I understand the ticket's description is that it is about including ore_algebra into sage itself (either as a package, or perhaps by making it part of the sage library, if Manuel & co are interested—I know they were considering it at some point, but I don't know how things are standing now). I could understand that you suggest to close the ticket as wontfix if you believe it should just stay an external package, but I don't think the issue is fixed.

comment:10 follow-up: Changed 5 years ago by rws

I do not suggest to close the ticket as wontfix. I never said that. What I expect is that someone sets positive, and since this ticket is in packages:optional I then expect the release manager to download the SPKG and himself copy the relevant files from that into build/... as well as providing the src/ as a tarball. BUT the mgt won't notice at all as long it's not positive.

Again, this ticket is in packages:optional, and that means when closed the package will be optional.

comment:11 in reply to: ↑ 10 Changed 5 years ago by mmezzarobba

  • Status changed from needs_review to positive_review

Replying to rws:

I do not suggest to close the ticket as wontfix. I never said that. What I expect is that someone sets positive, and since this ticket is in packages:optional I then expect the release manager to download the SPKG and himself copy the relevant files from that into build/... as well as providing the src/ as a tarball. BUT the mgt won't notice at all as long it's not positive.

Sorry, I never reviewed optional packages before, and I thought the idea was to use the ticket to review that the package worked well once all that was done, not to decide whether to make it an optional package at all. But if positive review only means "yes, this should be an optional package," then I agree with you.

comment:12 Changed 5 years ago by rws

  • Branch set to u/rws/inclusion_of_the_ore_algebra_within_sage

comment:13 Changed 5 years ago by rws

  • Cc mkauers added; rws removed
  • Commit set to 002e19f65ba5ccc0a3cc3b92000028d5522324b6
  • Reviewers set to Marc Mezzarobba, Ralf Stephan

Thanks. John Cremona clarified the procedure in https://groups.google.com/forum/#!topic/sage-devel/jopuoWO1Fvk


New commits:

002e19fTrac 16008: copy spkg-install and SPKG.txt into build/pkgs/ore-algebra

comment:14 Changed 5 years ago by vbraun

New-style optional packges must be tar.gz/tar.bz. We can include the existing spkg as optional, but then we don't need anything from the git branch.

comment:15 Changed 5 years ago by rws

So is there anything missing for this ticket?

comment:16 Changed 5 years ago by vbraun

The attached git branch is incomplete and there is no tarball. Is the ticket about updating the legacy spkg or creating a new-style optional package? I'm confused...

comment:17 Changed 5 years ago by rws

This is about taking the published SPKG and using it to create an optional package. You said elsewhere that a functional SPKG suffices for optional package creation. I created the branch before I knew that.

comment:18 Changed 5 years ago by vbraun

  • Branch u/rws/inclusion_of_the_ore_algebra_within_sage deleted
  • Cc schilly added
  • Commit 002e19f65ba5ccc0a3cc3b92000028d5522324b6 deleted
  • Description modified (diff)

Harald: can you mirror it?

comment:19 Changed 5 years ago by schilly

yes, done. ore_algebra is on the servers

comment:20 Changed 5 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.