Opened 8 years ago

Closed 7 years ago

#15814 closed defect (duplicate)

upgrade cunningham_table-1.0 and put it in standard

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: cunningham, factorization
Cc: roed Merged in:
Authors: Ralf Stephan Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by rws)

The old package still uses $SAGE_DATA and so it fails to install after sage-6.0. Moreover, it should be upgraded as the newest version is http://sage.math.washington.edu/home/roed/cunningham_tables-2.2.spkg

That version however still uses $SAGE_DATA but the upgrader could just fix that by changing usage of it to $SAGE_SHARE.

Maintainer is cc'ed.

See #7240 why this should be standard, the vote has happened.

Change History (7)

comment:1 Changed 8 years ago by rws

  • Component changed from packages: optional to packages: standard
  • Description modified (diff)
  • Summary changed from cunningham_table-1.0 fails to install, should be upgraded too to upgrade cunningham_table-1.0 and put it in standard

So, that's all to make the linked SPKG work:

diff -u --recursive cunningham_tables-2.2-old/spkg-install cunningham_tables-2.2/spkg-install
--- cunningham_tables-2.2-old/spkg-install      2009-10-17 22:46:12.000000000 +0200
+++ cunningham_tables-2.2/spkg-install  2014-02-21 09:42:48.599254970 +0100
@@ -1,4 +1,4 @@
 #!/bin/sh
 
-rm -rf $SAGE_DATA/cunningham_tables
-cp -r src/cunningham_tables $SAGE_DATA/cunningham_tables
+rm -rf $SAGE_SHARE/cunningham_tables
+cp -r src/cunningham_tables $SAGE_SHARE/cunningham_tables

Now to figure out what the actual patch should look like.

comment:2 Changed 8 years ago by rws

  • Authors set to Ralf Stephan
  • Status changed from new to needs_review

The sage-spkg script simply grabs any spkg-install in the tarball without looking into build/pkgs/cunningham_tables so, unless this has been enhanced, the only way to present this patched SPKG is by giving the patched spkg-install here as attachment.

So, to include the new package, download the SPKG from the link above, extract the tarball, and patch the spkg-install using the snippet above. The Sage tarball patch mechanism is not usable here, AFAIK, and neither is git.

Version 0, edited 8 years ago by rws (next)

comment:3 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 7 years ago by aapitzsch

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix

Duplicate of #15813.

comment:6 Changed 7 years ago by rws

  • Status changed from needs_review to positive_review

comment:7 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.