Opened 7 years ago

Closed 3 years ago

#15813 closed enhancement (wontfix)

make cunningham_tables-1.0.spkg standard and upgrade it

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: package, cunningham, factorization
Cc: roed Merged in:
Authors: David Roe, Ralf Stephan Reviewers:
Report Upstream: N/A Work issues:
Branch: u/rws/ticket/15813 (Commits, GitHub, GitLab) Commit: 7738db3a4e19b16e3dd03495e92444443e2c65a4
Dependencies: Stopgaps:

Status badges

Description (last modified by rws)

The optional spkg cunningham_tables-1.0 has no tickets, and is now available since sage-4.3.1. It is remarkably small.

According to #7240, it was voted to be included as standard. The newest version would be http://sage.math.washington.edu/home/roed/cunningham_tables-2.2.spkg

It however uses the obsolete SAGE_DATA, so a fixed version of the SPKG is attached. Also, in #7240 David Roe uploaded a patch that provides access to the tables. This is the first commit visible here. It however misses and changes some things.

Needed for #7240.

Attachments (1)

cunningham_tables-2.2.spkg (828.2 KB) - added by rws 7 years ago.
David Roe's spkg with SAGE_DATA fix

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by rws

  • Keywords package cunningham factorization added

comment:2 Changed 7 years ago by rws

  • Description modified (diff)

Changed 7 years ago by rws

David Roe's spkg with SAGE_DATA fix

comment:3 Changed 7 years ago by rws

  • Authors set to David Roe, Ralf Stephan
  • Cc roed added
  • Description modified (diff)

comment:4 Changed 7 years ago by rws

  • Branch set to u/rws/ticket/15813
  • Created changed from 02/13/14 09:00:56 to 02/13/14 09:00:56
  • Modified changed from 02/21/14 09:31:52 to 02/21/14 09:31:52

comment:5 Changed 7 years ago by rws

  • Commit set to 7d1204fcd9a647766d20cdd3dba5ed609203302f
  • Status changed from new to needs_review

I reverted David's unrelated changes to databases/install.py

@roed: David, if you want to deprecate database_install() please open a separate ticket.


New commits:

391d5f5Trac #7240: update cunningham_tables package to version 2.2
7d1204fTrac #15813: add ref to databases/all.py; revert silent changes to install.py

comment:6 Changed 7 years ago by git

  • Commit changed from 7d1204fcd9a647766d20cdd3dba5ed609203302f to 670fb1cd18fd8b3a3a3ffd9a7e07b29b1e32241e

Branch pushed to git repo; I updated commit sha1. New commits:

670fb1cMerge branch 'develop' into ticket/15813

comment:7 Changed 7 years ago by git

  • Commit changed from 670fb1cd18fd8b3a3a3ffd9a7e07b29b1e32241e to 7738db3a4e19b16e3dd03495e92444443e2c65a4

Branch pushed to git repo; I updated commit sha1. New commits:

7738db3Merge branch 'develop' into ticket/15813

comment:8 Changed 7 years ago by vbraun

We need a plain tarball (gz/bz2) for standard packages. David, can you make one?

comment:9 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:10 Changed 7 years ago by rws

  • Status changed from needs_review to needs_work

Some problem when buiding in patchbot. Set flag again when tarball available.

comment:11 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:12 Changed 3 years ago by rws

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to positive_review

The package is now not even experimental. The spkg is no longer available. The issue is superseded by #12133 because the Brent database contained the Cunningham tables.

So this is a duplicate.

comment:13 Changed 3 years ago by vdelecroix

  • Resolution set to wontfix
  • Status changed from positive_review to closed

closing positively reviewed duplicates

Note: See TracTickets for help on using tickets.