Opened 9 years ago

Closed 9 years ago

#15700 closed defect (fixed)

bdist fails because configure is not downloaded

Reported by: Volker Braun Owned by:
Priority: blocker Milestone: sage-6.1
Component: build Keywords:
Cc: Jeroen Demeyer Merged in:
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: u/vbraun/ticket/15700 (Commits, GitHub, GitLab) Commit: 8d352dde7846e8b199dd6be534c464573b9ac993
Dependencies: #15606 Stopgaps:

Status badges

Description

On my new OSX 10.9 buildbot I get:

$ ./sage -bdist
Sage version 6.1.beta5, release date 2014-01-15
Error: configure tarball '/Users/vbraun/Sage/upstream/configure-3.tar.gz' does not exist.
Run sage-autogen and try again.

Change History (13)

comment:1 Changed 9 years ago by Volker Braun

Jeroen, any thoughts? This would have worked if we had used "sage -f configure"....

comment:2 Changed 9 years ago by Volker Braun

Cc: Jeroen Demeyer added

comment:3 Changed 9 years ago by Jeroen Demeyer

Am I allowed to make this ticket depend on #15606 (to avoid conflicts)?

comment:4 Changed 9 years ago by Volker Braun

Go ahead...

comment:5 Changed 9 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Dependencies: #15606

comment:6 Changed 9 years ago by Jeroen Demeyer

Branch: u/jdemeyer/ticket/15700
Created: Jan 20, 2014, 9:30:15 PMJan 20, 2014, 9:30:15 PM
Modified: Jan 23, 2014, 10:12:13 AMJan 23, 2014, 10:12:13 AM

comment:7 Changed 9 years ago by Jeroen Demeyer

Commit: 575bbdffee06f75a75ded8f53facd227ec0cf4e5
Status: newneeds_review

New commits:

ac5c182Move checks from prereq.sh to configure
0f92bb1Merge branch 'ticket/15580' into ticket/15606
0a4e34eRevert changes to sage-update-version
fc1b607Symlink config.log to logs/pkgs/config.log
aee21c6Merge branch 'u/jdemeyer/ticket/15580' of git://trac.sagemath.org/sage into ticket/15606
2c2f372Move all bootstrapping to ./bootstrap
b1d5009Merge tag '6.1.beta6' into t/15606/ticket/15606
f10ca8fbump confball version
575bbdfsage-clone-source: allow downloading the configure tarball

comment:8 Changed 9 years ago by Volker Braun

Reviewers: Volker Braun

comment:9 Changed 9 years ago by Volker Braun

Branch: u/jdemeyer/ticket/15700u/vbraun/ticket/15700

comment:10 Changed 9 years ago by Volker Braun

Resolution: fixed
Status: needs_reviewclosed

comment:11 Changed 9 years ago by Volker Braun

Commit: 575bbdffee06f75a75ded8f53facd227ec0cf4e53f538924dc5b542cf6c2abdabc7ab5a4553024c7
Resolution: fixed
Status: closednew

First increment the version, then use the version number...


New commits:

3f53892bump confball version

comment:12 Changed 9 years ago by git

Commit: 3f538924dc5b542cf6c2abdabc7ab5a4553024c78d352dde7846e8b199dd6be534c464573b9ac993

Branch pushed to git repo; I updated commit sha1. New commits:

8d352ddonly use CONFVERSION after it has been incremented

comment:13 Changed 9 years ago by Volker Braun

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.