Opened 7 years ago

Closed 7 years ago

#15610 closed enhancement (duplicate)

Division field for an elliptic curve

Reported by: wuthrich Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: elliptic curves Keywords: elliptic curves, division field, torsion points, galois representation
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Currently there is a hidden function _division_field in gal_rep, that computes, for an elliptic curve over Q, the number field where all the p-torsion points are rational. This function should be made visible. One might also think about it for arbirary (number) fields.

Related to this is the proposed change #11905 to the function _splitting_field in the same file and the changes on #11271.

Change History (3)

comment:1 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-6.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Any reason why this is not a duplicate of #11905?

comment:2 Changed 7 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:3 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.