Changes between Initial Version and Version 1 of Ticket #15601, comment 38


Ignore:
Timestamp:
01/23/16 11:03:52 (7 years ago)
Author:
jdemeyer
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #15601, comment 38

    initial v1  
    55
    66I suggest to rename `check=True` to `value_from_pari=False` and replace `if not check and isinstance(f, pari_gen):` by `if value_from_pari:`.
     7
     8'''EDIT''': maybe it's better to move this code completely out of `__init__` and make a new classmethod `def construct_from_pari()` which bypasses `__init__` completely.