Opened 5 years ago

Last modified 10 months ago

#15538 new defect

CLI user interface shouldn't insist on everything being in Sage

Reported by: vbraun Owned by:
Priority: major Milestone: sage-7.4
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by chapoton)

Sage --help says that sage --M2 (for example) runs "Sage's Macaulay2", but it might actually run the system version. Especially since we don't have a working M2 spkg.

This needs to be checked in

  • src/bin/sage
  • src/doc/en/reference/repl/options.rst
  • src/sage/misc/dist.py

Change History (5)

comment:1 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:2 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:3 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:4 Changed 2 years ago by leif

  • Milestone changed from sage-6.4 to sage-7.4

comment:5 Changed 10 months ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.