Changes between Version 36 and Version 47 of Ticket #15530


Ignore:
Timestamp:
05/18/15 08:02:28 (5 years ago)
Author:
ohanar
Comment:

fyi, I started working on an autotools based build system for polybori at https://github.com/ohanar/PolyBoRi/tree/autotools. I'll probably work on it a bit more next weekend during SD 64.25, but the important bits (the c++ libraries) are currently working with only a couple of hacks. What remains (for sage at least) is just a little cleanup and throwing in the bit of the python bindings we use. I've created #18437 for future discussion of polybori and python 3.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #15530

    • Property Cc rws added
    • Property Dependencies changed from #15510, #15511, #15512, #15531, #15532, #15537, #15539, #15540, #15541, #15807, #15980 to #15510, #15511, #15512, #15531, #15532, #15537, #15539, #15540, #15541, #15807, #15980, pynac-0.3.8
  • Ticket #15530 – Description

    v36 v47  
    17171. #15980 - meta-ticket for python3 compatibility of the sage library (stage 1)
    18181. #16052 - meta-ticket for python3 compatibility of the sage library (stage 2)
    19 1. upgrade scons to a version that supports python3 (does not yet exist) or get rid of scons (assuming #17854, scons is only used by polybori)
    20 1. upgrade polybori to a version that supports python3 (does not yet exist)
     191. #17854 - remove c_lib
     201. #18437 - fix polybori and python 3
    21211. #17607 - add python 3 package
    2222