Opened 6 years ago

Closed 6 years ago

#15370 closed defect (fixed)

fix sage_mode optional spkg for git transition

Reported by: ohanar Owned by:
Priority: major Milestone: sage-5.13
Component: packages: optional Keywords:
Cc: aschilling, iandrus Merged in:
Authors: Ivan Andrus Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Currently the sage_mode spkg assumes that the SAGE_DATA is defined. This was deprecated in #13123, and will be removed in sage-6.0 (the git version).

I believe proper place to install the sage-mode is under SAGE_LOCAL/share/emacs/site-lisp/sage-mode.

spkg [​https://bitbucket.org/gvol/sage-mode/downloads/sage_mode-0.10.spkg]

Change History (5)

comment:1 Changed 6 years ago by iandrus

  • Authors set to Ivan Andrus
  • Status changed from new to needs_review

There is a new spkg up at https://bitbucket.org/gvol/sage-mode/downloads/sage_mode-0.10.spkg

It should work with both git and non-git versions of sage.

comment:2 Changed 6 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

Looks good to me

comment:3 Changed 6 years ago by jdemeyer

  • Description modified (diff)

comment:4 Changed 6 years ago by schilly

spkg updated.

comment:5 Changed 6 years ago by jdemeyer

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.