Opened 6 years ago

Closed 6 months ago

#15338 closed defect (worksforme)

Cygwin/Windows seems unable to deal with two different dlls with the same name

Reported by: jpflori Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: dimpase, embray Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

With the latest versions of Sage, I'm unable to build the doc in parallel because it seems that Cywgin/Windows? fails to load two different dlls with the same name.

More precisely the problem occured with function.pyx both in sage/symbolic and sage/libs/singular.

Changing the name of one of this files solved the problem.

Change History (6)

comment:1 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:2 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:3 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:4 Changed 3 years ago by jdemeyer

  • Cc embray added

Is this still an issue? Given that @embray never mentioned this, I would guess not.

comment:5 Changed 3 years ago by embray

It might still be. I've never had parallel doc builds working, though I'm not sure whether or not this is the reason.

comment:6 Changed 6 months ago by embray

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Resolution set to worksforme
  • Status changed from new to closed

Parallel doc build works fine for me, and this should not be a problem. Clashing DLL filenames should only be a problem, AFAIK, for implicitly loaded DLLs.

Note: See TracTickets for help on using tickets.