Opened 14 years ago

Closed 14 years ago

#153 closed enhancement (duplicate)

automated testing of the whole SAGE install

Reported by: was Owned by: was
Priority: major Milestone:
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Add the following:

  sage -i -t packagename.spkg

will build and install the package and run whatever the standard tests are for that package. The tests will be run by running

  spkg-test

if that script is in the package. Otherwise, it always reports failure. Then I go through and figure out what the test suite is for each package, and get it to work.

Have a "make safe" which does build of all of SAGE but at each point running the tests.

William

Change History (1)

comment:1 Changed 14 years ago by mabshoff

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #299.

Cheers,

Michael

Note: See TracTickets for help on using tickets.