Changes between Initial Version and Version 1 of Ticket #15299, comment 18


Ignore:
Timestamp:
Nov 4, 2013, 7:34:51 PM (9 years ago)
Author:
Jeroen Demeyer
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #15299, comment 18

    initial v1  
    11Replying to [comment:17 pbruin]:
    22> Jeroen, do you have a particular reason for writing `QQ()` and `R()` instead of `QQ(0)` and `R(0)`?  It saves one character, but is less readable.
    3 No reason, it's just to habit to think in term of default constructors (I guess this is my C++ background). I just benchmarked `QQ()`, `QQ(0)` and `QQ.zero()` and the latter is the fastest, so perhaps we should use that.
     3No reason, it's just a habit to think in term of default constructors (I guess this is my C++ background). I just benchmarked `QQ()`, `QQ(0)` and `QQ.zero()` and the latter is the fastest, so perhaps we should use that.