Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#15259 closed enhancement (duplicate)

(v,4,1)-BIBD, Latin Squares and Orthogonal arrays

Reported by: ncohen Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: dimpase, vbraun, wdj, rbeezer Merged in:
Authors: Reviewers: Nathann Cohen
Report Upstream: N/A Work issues:
Branch: u/ncohen/15259 (Commits, GitHub, GitLab) Commit: ffda584fb317a7d19a41046bfeaff584aa66d9c3
Dependencies: #15107 Stopgaps:

Status badges

Description (last modified by ncohen)

WUUUUHUUUUUUUUUUUUUUUUUU !!

This patch implements a construction from Douglas Stinson's book "Combinatorial Designs: Constructions and Analysis" for (v,4,1)-BIBD, i.e. decompositions of K_v into copies of K_4. It requires the construction of some other combinatorial objects, like some Mutually Orthogonal Latin Squares and Orthogonal Arrays, an so some theorems from this book are also implemented by this patch. Hoping that the new files will get larger eventually :-)

I also fixed a bug in AffineGeometryDesign : a List is used instead of a Set, and as a result blocks are returned several times. Example :

Before

sage: print designs.AffineGeometryDesign(2, 1, GF(2)).blocks()
[[0, 1], [0, 1], [0, 2], [0, 2], [0, 3], [0, 3], [1, 2], 
 [1, 2], [1, 3], [1, 3], [2, 3], [2, 3]]

After

sage: print designs.AffineGeometryDesign(2, 1, GF(2)).blocks()
[[0, 1], [0, 2], [0, 3], [1, 2], [1, 3], [2, 3]]

Overall :

  • A file named bibd.py now gathers steiner_triple_systems (moved there from block_designs.py). It also implement the present construction, and a general BalancedIncompleteBlockDesign is created to obtain both steiner triple systems and (v,4,1)-BIBD. And even some others from the online database.
  • A file named latin_squares.py contains constructions for mutually orthogonal latin squares, as well as a function to compute the product of two latin squares.
  • A file named orthogonal_arrays.py contains constructions for orthogonal arrays and transversal designs (which are a particular case of orthogonal arrays.

The most important thing is that even if all the code written there is wrong (and it is indeed very unclear at times), nothing is returned without being checked first for correctness.

Sooooooooooo well. It's rather safe ;-)

Have fuuuuuuuuuuuuun !

Nathann

Change History (11)

comment:1 Changed 8 years ago by ncohen

  • Branch set to u/ncohen/15259
  • Status changed from new to needs_review

comment:2 Changed 8 years ago by git

  • Commit set to 2d09d1d1c209e4815b2b11c80d626b71b076c6ce

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

[changeset:2d09d1d](v,4,1)-BIBD, Latin Squares and Orthogonal arrays
[changeset:3f1c8f6]Rebase 15107 over 5.12.beta5
[changeset:3b15578]Merging Sage-5.12.beta5, newest dev scripts, and the doctest fixes.
[changeset:1456c52]Merge branch 'ticket/14482' into public/sage-git/master
[changeset:b890215]Merge branch 'ticket/14482' into public/sage-git/master
[changeset:d8713eb]Merge remote-tracking branch 'origin/build_system' into public/sage-git/master
[changeset:9fcfb13]Rename the method from ProjectivePlaneDesign? to DesarguesianProjectivePlaneDesign?
[changeset:363badb]trac 15107 -- reviewer's comments
[changeset:ee6d412]Projective Plane designs constructor
[changeset:970090d]Merge branch 'u/ohanar/build_system'

comment:3 Changed 8 years ago by git

  • Commit changed from 2d09d1d1c209e4815b2b11c80d626b71b076c6ce to cb2fce9c634be27a3a3905577ea97cc356ffd8a4

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

[changeset:cb2fce9](v,4,1)-BIBD, Latin Squares and Orthogonal arrays
[changeset:3f1c8f6]Rebase 15107 over 5.12.beta5
[changeset:3b15578]Merging Sage-5.12.beta5, newest dev scripts, and the doctest fixes.
[changeset:1456c52]Merge branch 'ticket/14482' into public/sage-git/master
[changeset:b890215]Merge branch 'ticket/14482' into public/sage-git/master
[changeset:d8713eb]Merge remote-tracking branch 'origin/build_system' into public/sage-git/master
[changeset:9fcfb13]Rename the method from ProjectivePlaneDesign? to DesarguesianProjectivePlaneDesign?
[changeset:363badb]trac 15107 -- reviewer's comments
[changeset:ee6d412]Projective Plane designs constructor
[changeset:970090d]Merge branch 'u/ohanar/build_system'

comment:4 Changed 8 years ago by rbeezer

  • Cc rbeezer added

comment:5 Changed 8 years ago by ncohen

  • Description modified (diff)

comment:6 Changed 8 years ago by git

  • Commit changed from cb2fce9c634be27a3a3905577ea97cc356ffd8a4 to 944784c5dc9183263b6ac9e6fe395719b7e8f483

Branch pushed to git repo; I updated commit sha1. New commits:

[changeset:944784c]designs.BalancedIncompleteBlockDesign? feeds upon Finite Projective Planes ||

comment:7 Changed 8 years ago by git

  • Commit changed from 944784c5dc9183263b6ac9e6fe395719b7e8f483 to aa7299ffe5ed56b0771cf8bdde13303a7aacf907

Branch pushed to git repo; I updated commit sha1. New commits:

[changeset:aa7299f]designs.BalancedIncompleteBlockDesign? : todo notes for later

comment:8 Changed 7 years ago by git

  • Commit changed from aa7299ffe5ed56b0771cf8bdde13303a7aacf907 to ffda584fb317a7d19a41046bfeaff584aa66d9c3

Branch pushed to git repo; I updated commit sha1. New commits:

[changeset:ffda584]Rebase on 5.12.beta5

comment:9 Changed 7 years ago by ncohen

  • Milestone changed from sage-5.13 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

This patch has been split in smaller patches, and this ticket is now a duplicate of #15288 (and its dependencies #15287 #15286 and #15285)

Nathann

comment:10 Changed 7 years ago by jdemeyer

  • Authors Nathann Cohen deleted
  • Resolution set to duplicate
  • Reviewers set to Nathann Cohen
  • Status changed from positive_review to closed

comment:11 Changed 7 years ago by ncohen

For a split second I believed that #15288 had been reviewed T_T

Nathann

Note: See TracTickets for help on using tickets.