Opened 9 years ago

Closed 9 years ago

#15244 closed defect (fixed)

sage -t outputs duplicate lines

Reported by: Jeroen Demeyer Owned by:
Priority: critical Milestone: sage-5.13
Component: doctest framework Keywords:
Cc: David Roe Merged in: sage-5.13.beta2
Authors: Jeroen Demeyer Reviewers: David Roe
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

Normally, this should be zero:

$ rm -f logs/ptest.log
$ make ptest
$ grep '^sage -t' logs/ptest.log  |sort |uniq -d |wc --lines
436

This is caused by forking with unflushed buffers.

Attachments (1)

15244_doctest_flush.patch (1.3 KB) - added by Jeroen Demeyer 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Description: modified (diff)

Changed 9 years ago by Jeroen Demeyer

Attachment: 15244_doctest_flush.patch added

comment:2 Changed 9 years ago by Jeroen Demeyer

Cc: David Roe added
Description: modified (diff)
Status: newneeds_review

comment:3 Changed 9 years ago by David Roe

Status: needs_reviewpositive_review

That looks fine to me.

comment:4 Changed 9 years ago by Jeroen Demeyer

Reviewers: David Roe

comment:5 Changed 9 years ago by Jeroen Demeyer

Merged in: sage-5.13.beta2
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.