Opened 8 years ago

Closed 5 years ago

#15211 closed defect (fixed)

Link p-adics tutorial from number theory tour

Reported by: roed Owned by:
Priority: trivial Milestone: sage-7.2
Component: padics Keywords:
Cc: Merged in:
Authors: Dima Pasechnik Reviewers: Chris Nicholls
Report Upstream: N/A Work issues:
Branch: a48f0f5 (Commits, GitHub, GitLab) Commit: a48f0f5e04618a173ecdf712073bcabaacb60128
Dependencies: Stopgaps:

Status badges

Description

As requested by a user, it would be nice to have a link from tour_numtheory.html#adic-numbers to doc/reference/padics/sage/rings/padics/tutorial.html.

Change History (16)

comment:1 Changed 8 years ago by roed

  • Summary changed from Link p-adics tutoiral from number theory tour to Link p-adics tutorial from number theory tour

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 5 years ago by dimpase

the link would ideally go to the internal reference manual entry, rather than to URL, IMHO.

comment:6 Changed 5 years ago by dimpase

  • Authors set to Dima Pasechnik
  • Branch set to u/dimpase/t15211
  • Commit set to e4380b588eda1cb445e51bf961457a932f081daa
  • Milestone changed from sage-6.4 to sage-7.2

New commits:

e4380b5added :ref: link

comment:7 Changed 5 years ago by dimpase

  • Status changed from new to needs_review

comment:8 Changed 5 years ago by cgnicholls

  • Branch changed from u/dimpase/t15211 to u/cgnicholls/t15211

comment:9 Changed 5 years ago by cgnicholls

  • Commit changed from e4380b588eda1cb445e51bf961457a932f081daa to 9b61842cf2efffaddf97fcc098d95e701edeb169

Fixed a sentence that didn't make sense.


New commits:

9b61842Improved Tour of Number Theory.

comment:10 Changed 5 years ago by cgnicholls

  • Reviewers set to Chris Nicholls
  • Status changed from needs_review to positive_review

comment:11 follow-up: Changed 5 years ago by vbraun

  • Status changed from positive_review to needs_work
sage -t --long src/doc/common/conf.py
**********************************************************************
File "src/doc/common/conf.py", line 615, in doc.common.conf.call_intersphinx
Failed example:
    for line in open(thematic_index).readlines():
        if "padics" in line:
            sys.stdout.write(line)
Expected:
    <li><a class="reference external" href="../reference/padics/sage/rings/padics/tutorial.html#sage-rings-padics-tutorial" title="(in Sage Reference Manual: p-Adics ...)"><em>Introduction to the p-adics</em></a></li>
Got:
    <li><a class="reference external" href="../reference/padics/sage/rings/padics/tutorial.html#sage-rings-padics-tutorial" title="(in Sage Reference Manual: p-Adics v7.2.beta0)"><em>Introduction to the -adics</em></a></li>
**********************************************************************
1 item had failures:
   1 of   4 in doc.common.conf.call_intersphinx
    [3 tests, 1 failure, 0.01 s]

comment:12 in reply to: ↑ 11 Changed 5 years ago by dimpase

Replying to vbraun:

sage -t --long src/doc/common/conf.py
**********************************************************************
File "src/doc/common/conf.py", line 615, in doc.common.conf.call_intersphinx
Failed example:
    for line in open(thematic_index).readlines():
        if "padics" in line:
            sys.stdout.write(line)
Expected:
    <li><a class="reference external" href="../reference/padics/sage/rings/padics/tutorial.html#sage-rings-padics-tutorial" title="(in Sage Reference Manual: p-Adics ...)"><em>Introduction to the p-adics</em></a></li>
Got:
    <li><a class="reference external" href="../reference/padics/sage/rings/padics/tutorial.html#sage-rings-padics-tutorial" title="(in Sage Reference Manual: p-Adics v7.2.beta0)"><em>Introduction to the -adics</em></a></li>
**********************************************************************
1 item had failures:
   1 of   4 in doc.common.conf.call_intersphinx
    [3 tests, 1 failure, 0.01 s]

I cannot reproduce this. Did you rebuild docs after applying the patch?

comment:13 Changed 5 years ago by dimpase

  • Status changed from needs_work to positive_review

re-tested, it works.

comment:14 Changed 5 years ago by vbraun

  • Status changed from positive_review to needs_work

Still fails, duh. E.g. http://build.sagedev.org/release/builders/%20%20slow%20AIMS%20%20%28Debian%208%2032%20bit%29%20incremental/builds/450 but really fails on the whole buildbot.

And yes we do make doc-clean

comment:15 Changed 5 years ago by dimpase

  • Branch changed from u/cgnicholls/t15211 to u/dimpase/t15211
  • Commit changed from 9b61842cf2efffaddf97fcc098d95e701edeb169 to a48f0f5e04618a173ecdf712073bcabaacb60128
  • Status changed from needs_work to positive_review

oops, indeed. It'd really a bug in sphinx, IMHO, that one needs to clean docs for such an update to go through. Anyway.


New commits:

649b7d7Merge branch 'u/cgnicholls/t15211' of trac.sagemath.org:sage into padlink
a48f0f5backquoted things are funny

comment:16 Changed 5 years ago by vbraun

  • Branch changed from u/dimpase/t15211 to a48f0f5e04618a173ecdf712073bcabaacb60128
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.