Opened 15 years ago

Closed 15 years ago

#1508 closed defect (fixed)

[with patch, positive review] axes_label in plot() broken

Reported by: William Stein Owned by: William Stein
Priority: major Milestone: sage-2.10.1
Component: graphics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Notice, if you tab-complete plot( or list_plot( the docs do not
mention the option for axes_label.  However, the option is available.

Also, if you use them, the text for the x-axis is truncated off the
right edge of the plot.

Simple example:

p = plot(sin, 0, 10)
p.show(axes_label=['x-axis','y-axis'])

Attachments (2)

doc-trac-1508.patch (884 bytes) - added by William Stein 15 years ago.
fixes a mistake in const.tex
trac-1508.patch (17.1 KB) - added by William Stein 15 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 years ago by William Stein

Status: newassigned

Changed 15 years ago by William Stein

Attachment: doc-trac-1508.patch added

fixes a mistake in const.tex

Changed 15 years ago by William Stein

Attachment: trac-1508.patch added

comment:2 Changed 15 years ago by Michael Abshoff

Summary: axes_label in plot() broken[with patch, needs review] axes_label in plot() broken

comment:3 Changed 15 years ago by Mike Hansen

Summary: [with patch, needs review] axes_label in plot() broken[with patch, positive review] axes_label in plot() broken

Looks good to me.

comment:4 Changed 15 years ago by Michael Abshoff

I am having reject issues with this against Sage 2.10.1.alpha0

Cheers,

Michael

comment:5 Changed 15 years ago by Michael Abshoff

Resolution: fixed
Status: assignedclosed

Merged in Sage 2.10.1.alpha1. The reject mentioned above was caused by interaction from #1859 - I resolved those manually.

Cheers,

Michael

Note: See TracTickets for help on using tickets.