Opened 8 years ago

Closed 6 years ago

#14979 closed defect (duplicate)

GUAVA failures for linear codes

Reported by: niles Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: coding theory Keywords:
Cc: wdj Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Working on #14909, we discovered some failing doctests for the GAP package GUAVA. For example:

sage: F.<a> = GF(4)
sage: C = HammingCode(2,F)
sage: v = vector(F, [1,0,0,a,1])
sage: C.decode(v)
(a + 1, 0, 0, a, 1)
sage: C.decode(v, algorithm="nearest neighbor")
(a + 1, 0, 0, a, 1)
sage: C.decode(v, algorithm="guava")  # optional - gap_packages (Guava package)
BOOM!

There are other failures for permutation_automorphism_group too.

Change History (8)

comment:1 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:3 Changed 7 years ago by ppurka

signing in to keep track of this ticket.

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 6 years ago by danielaugot

Could you please tell us what is "BOOM" ? I got two different BOOMs, depending on the installation of guava. Daniel

comment:6 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #16660.

comment:7 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:8 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.