Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#14816 closed enhancement (fixed)

Implement absolute order for coxeter groups

Reported by: sam Owned by: sage-combinat
Priority: minor Milestone: sage-6.2
Component: combinatorics Keywords: coxeter, days49
Cc: kdilks Merged in:
Authors: Kevin Dilks, Sam Clearman Reviewers: Frédéric Chapoton, Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 3a919ba (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description

The absolute order is defined analogously to the weak order, but using all reflections rather than just the simple reflections.

Attachments (2)

trac_14816-absolute-order-sjc.patch (2.9 KB) - added by sam 9 years ago.
trac_14816_addon1_fc.patch (7.3 KB) - added by chapoton 9 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 9 years ago by sam

  • Component changed from PLEASE CHANGE to combinatorics
  • Owner changed from tbd to sage-combinat
  • Priority changed from major to minor

Changed 9 years ago by sam

comment:2 Changed 9 years ago by kdilks

  • Cc kdilks added

comment:3 Changed 9 years ago by chapoton

you need to add documentation (with examples) to every function

comment:4 Changed 9 years ago by chapoton

  • Keywords coxeter added

Changed 9 years ago by chapoton

comment:5 Changed 9 years ago by chapoton

here is a patch adding documentation

I have also switched from RR to the Universal cyclotomic field.

comment:6 follow-up: Changed 9 years ago by chapoton

this ticket is related to #9290

comment:7 in reply to: ↑ 6 Changed 8 years ago by sam

Replying to chapoton:

this ticket is related to #9290

Yes... should we wait for that patch to get written and then rewrite this to work on coxeter groups in general, or just submit this as it is?

comment:8 Changed 8 years ago by tscrim

To cc myself on this ticket and to note that #9290 is positively reviewed.

comment:9 Changed 8 years ago by chapoton

  • Branch set to u/chapoton/14816
  • Commit set to f192d5a994e1638f7f45921bff737a6d0d92a7d3
  • Status changed from new to needs_info

Maybe time has come for this ticket now ?


New commits:

f192d5atrac 14816 cleanup patch
ecb04bdadd absolute order

comment:10 Changed 8 years ago by git

  • Commit changed from f192d5a994e1638f7f45921bff737a6d0d92a7d3 to f406b70ec0ac4dbb84d439ee2f04960da79940ef

Branch pushed to git repo; I updated commit sha1. New commits:

f406b70trac #14816 minor details

comment:11 Changed 8 years ago by chapoton

  • Status changed from needs_info to needs_review

Needs review, I think

comment:12 Changed 8 years ago by tscrim

  • Authors set to Kevin Dilks, sam
  • Branch changed from u/chapoton/14816 to public/combinat/absolute_order-14816
  • Commit changed from f406b70ec0ac4dbb84d439ee2f04960da79940ef to 5fd568ad2b66a1d2b927d642ab2488dd614c3eb8
  • Keywords days49 added
  • Reviewers set to Frederic Chapoton, Travis Scrimshaw

I think Kevin worked on this at Sage days 49, but IDK who the user "sam" is (if you're reading this, please add in your real name).

I agree that we should review this. I've moved stuff into the CoxeterGroups category, which is where the comments suggested they belong, and I added the methods to make it all work.


New commits:

4a6840aMerge branch 'u/chapoton/14816' of trac.sagemath.org:sage into public/combinat/absolute_order-14816
5fd568aRefactored into the appropriate categories.

comment:13 Changed 8 years ago by chapoton

  • Reviewers changed from Frederic Chapoton, Travis Scrimshaw to Frédéric Chapoton, Travis Scrimshaw

comment:14 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:15 Changed 8 years ago by git

  • Commit changed from 5fd568ad2b66a1d2b927d642ab2488dd614c3eb8 to de61241d89322ebb77a37c20ca49689b1d923e3b

Branch pushed to git repo; I updated commit sha1. New commits:

de61241Merge branch 'develop' into public/combinat/absolute_order-14816

comment:16 Changed 8 years ago by chapoton

Why does this remove almost completely the file root_system/weyl_group.py ?

This seems wrong. Travis, do you understand why ?

comment:17 Changed 8 years ago by git

  • Commit changed from de61241d89322ebb77a37c20ca49689b1d923e3b to 3a919ba6760794f6f7d8c13881d18fe42bd38ceb

Branch pushed to git repo; I updated commit sha1. New commits:

3a919baMerge branch 'public/combinat/absolute_order-14816' of trac.sagemath.org:sage into public/combinat/absolute_order-14816

comment:18 Changed 8 years ago by tscrim

There was something wrong a while ago with the trac plugin and I believe it just didn't update itself since. Anyways, once I had pulled and merged with my development branch, everything was good (as trac now reflects).

comment:19 Changed 8 years ago by chapoton

  • Status changed from needs_review to positive_review

ok, this looks good enough to me

positive review

:)

comment:20 Changed 8 years ago by vbraun

  • Status changed from positive_review to needs_work

There are some infinite recursions in cmp that are probably caused by this ticket. Run the doctests, kids ;)

comment:21 Changed 8 years ago by vbraun

Ok, the doctest failures were due to #15978 and not this ticket. Never mind.

But who is "sam", is that really his full name? Lower case and all?

comment:22 Changed 8 years ago by sam

Sam Clearman. I put my full name in the preferences but I guess that doesn't do anything?

comment:23 Changed 8 years ago by vbraun

  • Authors changed from Kevin Dilks, sam to Kevin Dilks, Sam Clearman
  • Status changed from needs_work to positive_review

No, you have to fill it in the Author field yourself.

comment:24 Changed 8 years ago by vbraun

  • Branch changed from public/combinat/absolute_order-14816 to 3a919ba6760794f6f7d8c13881d18fe42bd38ceb
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:25 Changed 8 years ago by chapoton

  • Commit 3a919ba6760794f6f7d8c13881d18fe42bd38ceb deleted

One should have used .rank() instead of .image().dimension(), for speed. This will be for another ticket.

Note: See TracTickets for help on using tickets.